PhoA

PhoA — Arrange Your Pictures!

Copyright ©2002-2005 DK Software, www.dk-soft.org


Назначение программы

В наши дни всё более популярным становится хранение изображений в виде компьютерных файлов. Безусловно, этот способ хранения обладает явными преимуществами по сравнению с хранением "бумажных" фотографий, рисунков и т. д.: электронное изображение не занимает столько места (на обычный записываемый CD-R-диск входит около 5000 фотографий в формате JPEG вполне достойного качества), его легко копировать, показать и даже подарить совсем всем своим и чужим родственникам, друзьям и врагам (последним его можно отправить по электронной почте, так будет даже лучше, если его размер превышает 10-20 мегабайт).

Однако при большом количестве изображений (те же несколько тысяч) их становится крайне трудно найти. Наиболее очевидным и простым способом является раскладывание файлов с изображениями по папкам, соответственно их называя ("Мы с нашей собакой", "Собака без нас" и т. д.), но тут возникает множество неразрешимых противоречий: а как быть, если нужно организовать изображения по датам и одновременно по действующим лицам, по событиям и по местам действий; как связать описание изображения с этим изображением (правда, некоторые программы позволяют вписать текст в сам файл изображения, но уж больно неудобно они это делают); как, наконец, найти из 1287 изображений Вас и Вашей собаки то единственное (и, возможно, последнее), где она прыгает к Вам с пятого этажа?

Все эти нехитрые, казалось бы, задачи и подвигли меня на создание программы для каталогизации: упорядочивания и поиска различных изображений (рисунков, фотографий, скриншотов и всего остального).

Нравится Вам это или нет, но программа получила название PhoA — акроним от словосочетания 'Photo Album', и файлы фотоальбомов, создаваемые программой, также имеют расширение .phoa.

Дальше >>

Авторское право ©2002-2005 DK Software. Все права сохранены.


Как это работает

В основу работы программы положен принцип хранения ссылок на изображения, точнее, на файлы изображений. Поскольку сами изображения хранятся отдельно, их, во-первых, можно легко копировать независимо от программы, во-вторых, просматривать любыми сторонними программами, а в-третьих, не тратится места при копировании ссылки на изображение.

Изображения собираются в группы, а сами группы организовываются иерархически, в виде вложенных папок, в точности, как папки в Проводнике. Группы отображаются в программе в виде папок в левой части окна программы, а входящие в группу изображения — в правой части.

Следует заметить, что группы содержат, опять же, не непосредственные ссылки на изображения. Ссылки на изображения формируют в PhoA некоторый "обменный фонд", общий список изображений, каждый элемент которого содержит данные описания.

Из этого общего списка ссылок составляются группы, то есть группы содержат "ссылки на ссылки на изображения". Тем, кого эти объяснения только запутывают, советую взглянуть на рисунок:

О чём он нам говорит? Он нам говорит о том, что единожды описав изображение на диске, вы можете добавлять его во сколько угодно групп (хоть во все сразу), при этом все эти добавленные изображения в действительности будут иметь лишь одну ссылку на файл и лишь одно описание (дату, место, ключевые слова, описание, эскиз и т. д.).

Дальше >>


Форматы файлов

Как было сказано ранее, программа PhoA работает с файлами фотоальбомов, имеющими расширение .phoa — такой файл содержит в себе:

  • текст описания и параметры фотоальбома;
  • список изображений вместе с их описаниями;
  • иерархию групп-папок, каждая из которых содержит набор ссылок на список изображений фотоальбома.
  • список структур представлений (PhoA версии 1.0.1+).

Файл .phoa недоступен для непосредственного просмотра и открывается только программой PhoA. Начиная с версии программы 1.1.1a возможно также создание собственных инструментов благодаря открытым подробным спецификациям формата PhoA. Более детальная информация находится на сайте программы.

В качестве исходных изображений данная версия программы принимает файлы следующего формата (кликните на кнопке с плюсиком, чтобы развернуть детали):

Стандартные изображения Windows и OS/2 bitmap (*.bmp, *.rle, *.dib)

  • byte order: little endian
  • sample sizes: 1, 4, 8 bits per sample
  • color spaces: indexed, RGB(A)
  • compression formats: uncompressed, RLE

Файлы JPEG (*.jpg; *.jpeg; *.jpe)

  • byte orders: little endian, big endian
  • sample sizes: 8 bits per sample
  • color spaces: grayscale, RGB

Файлы TIFF (*.tif; *.tiff; *.dng)

  • byte orders: little endian, big endian
  • sample sizes: 1, 2, 4, 8, 16 bits per sample
  • color spaces: indexed, grayscale, RGB(A), CMYK, L*a*b*
  • compression formats: uncompressed, packed bits, LZW, CCITT T.4 (raw and modified fax group 3, possibly word aligned), ThunderScan, Deflate, new style JPEG

Файлы GFI fax (*.fax)

  • sample size: 1 bits per sample
  • color space: indexed
  • compression format: CCITT T.4 (raw and modified fax group 3)

Файлы SGI (*.bw, *.rgb, *.rgba, *.sgi)

  • byte order: big endian
  • sample sizes: 1, 2, 4, 8, 16 bits per sample
  • color spaces: indexed, grayscale, RGB(A)
  • compression formats: uncompressed, RLE

Файлы Autodesk (*.cel; *.pic)

  • byte order: little endian
  • sample size: 8 bits per sample
  • color spaces: indexed
  • compression format: uncompressed

Файлы Truevision Targa (*.tga; *.vst; *.icb; *.vda; *.win)

  • byte order: little endian
  • sample sizes: 5, 8 bits per sample
  • color spaces: gray scale, indexed, 15 bits RGB (555), 24 bits RGB(A)(888)
  • compression formats: uncompressed, RLE

Файлы ZSoft Paintbrush (*.pcx, *.pcc)

  • byte order: little endian
  • sample sizes: 1, 2, 4, 8 bits per sample
  • color spaces: gray scale, indexed, RGB
  • compression formats: uncompressed, RLE

Файлы Word 5.x screen capture (*.scr)

  • byte order: little endian
  • sample sizes: 1, 2, 4, 8 bits per sample
  • color spaces: indexed, gray scaleRGB
  • compression formats: uncompressed, RLE

Файлы Kodak Photo-CD (*.pcd)

  • byte order: little endian
  • samples size: 8 bits per sample
  • color space: YCbCr
  • compression: PCD Huffmann
  • specials:
    • sizes: all resolutions, from 192 x 128 up to 6144 x 4096 (64 Base vaporware)
    • rotated: clockwise and counter-clockwise

Файлы Portable pixel/gray map (*.ppm, *.pgm, *.pbm)

  • byte order: little endian
  • sample sizes: 1, 8 bits per sample
  • color spaces: gray scale, indexed, RGB
  • compression format: uncompressed
  • specials:
    • ASCII and Binary format

Файлы Dr. Halo (*.cut, *.pal)

  • byte order: little endian
  • sample size: 8 bits per sample
  • color spaces: indexed
  • compression formats: RLE
  • specials:
    • external palette file (*.pal) is automatically loaded

Файлы CompuServe GIF (*.gif)

  • byte order: little endian
  • sample sizes: 1, 4, 8 bits per sample
  • color spaces: indexed
  • compression format: LZW
  • specials:
    • interlaced, non-interlaced

Файлы SGI Wavefront (*.rla, *.rpf)

  • byte order: big endian
  • sample size: 8 bits per sample
  • color space: RGB(A)
  • compression formats: RLE

Файлы Photoshop (*.psd, *.pdd)

  • byte order: big endian
  • sample sizes: 1, 8, 16 bits per sample
  • color spaces: indexed, RGB, CMYK, CIE L*a*b*
  • compression formats: uncompressed, packed bits
  • special:
    • duo tone

Файлы Paint Shop Pro (*.psp)

  • byte order: little endian
  • sample sizes: 1, 4, 8 bits per sample
  • color spaces: indexed, gray scale, RGB
  • compression formats: uncompressed, LZ77

Файлы Portable Network Graphic (*.png)

  • byte order: big endian
  • sample sizes: 1, 2, 4, 8, 16 bits per sample
  • color spaces: indexed, grayscale (alpha), RGB(A)
  • compression format: LZ77
  • specials:
    • supported chunks: IHDR, IDAT, IEND, PLTE, gAMA, tRNS, bKGD
    • transparency support partially for RGB, which is stored as 32 bits format

Мощная поддержка форматов изображений реализована благодаря Mike Lischke.

Дальше >>


Эскизы

Максимальный размер эскизов, создаваемых для заносимых изображений, определяется свойствами фотоальбома (то есть каждый фотоальбом может иметь свои настройки размера эскиза) и по умолчанию равен 150х150 пикселов. Если изображение больше этого размера, то эскиз получается путём соответствующего масштабирования картинки.

Хранятся эскизы PhoA всегда в формате JPEG, что обусловлено наиболее эффективным сжатием этого формата. Вы можете контролировать качество получаемых эскизов с помощью настроек программы: чем выше качество эскиза, тем легче по нему узнать исходное изображение, но тем больше он занимает места. Поскольку эскизы сохраняются в файлах фотоальбомов (*.phoa), размеры и качество эскизов напрямую влияют на размер файла фотоальбома и на занимаемый фотоальбомом объём памяти при его открытии.

Дальше >>


Режимы работы программы

Программа PhoA имеет два основных режима работы:

  • обзор и упорядочивание изображений;
  • просмотр изображений.

Эти режимы функционально практически скопированы с одной известной программы (не будем называть фамилии). Ведь зачем изобретать велосипед?

Режим обзора

В этом режиме главное окно программы очень напоминает стандартный Проводник Windows: в левой части расположено дерево групп-папок, а в правой отображаются эскизы и описания изображений, находящихся в выбранной слева группе. В этом режиме Вы можете создавать новые группы в фотоальбоме, добавлять, удалять и изменять изображения в группах, перетаскивать и копировать изображения из одной группы в другую и производить различные сервисные операции.

подробнее >>

Просмотр

Было бы странно, если бы программа для каталогизации изображений не обладала удобным средством их просмотра. В PhoA данный режим позволяет производить просмотр отдельных изображений — исходных, то есть тех, на основе которых построены эскизы в фотоальбоме. При просмотре имеются функции увеличения/уменьшения изображения и прокрутки его на экране, перехода к следующему, предыдущему, первому и последнему изображению в группе, переключения из оконного в полноэкранный режим и обратно.

подробнее >>

Дальше >>


Характеристики и преимущества PhoA

Совершенно несомненно, что PhoA даёт ряд неоспоримых преимуществ при работе с фотографиями, рисунками и прочими воплощениями разных художественных замыслов:

  • Программа не требует установки и (пока) состоит из одного-единственного файла phoa.exe. Что это даёт? Это даёт возможность копировать её вместе с созданным файлом фотоальбома (*.phoa) всюду, где только пожелается. Если положить её на CD-ROM-диск, а в корневой каталог диска поместить соответствующий файл autorun.inf, то Вы сможете демонстрировать Ваши изображения на любом компьютере, просто вставив диск в привод CD-ROM (на компьютерах, где включена функция автозапуска CD-дисков). Программа не обидится, даже если рядом не окажется файла phoa.chm (Справочной системы PhoA).
  • Программа позволяет строить каталоги (называемые фотоальбомами) из совершенно разнородных изображений. Организуются изображения в виде групп-папок наподобие папок в Проводнике Windows. В качестве исходных файлов PhoA принимает практически любые растровые, а также некоторые векторные форматы.
  • Для каждого изображения Вы можете ввести дату, место, номер плёнки и кадра, ключевые слова, описание, автора и пр. Автоматически создаётся эскиз — уменьшенный вариант исходного изображения (поддерживаются несколько вариантов ресэмплинга). Размер эскизов задаётся в параметрах фотоальбома, сами эскизы сохраняются в файле фотоальбома, что позволяет открывать и просматривать фотоальбомы практически мгновенно. Эскизы сжимаются по алгоритму JPEG.
  • PhoA позволяет производить мгновенный поиск в созданных фотоальбомах по любым данным: по имени файла, по диапазону дат, по наименованию места, ключевым словам и тексту описания изображения и т. д.; результаты поиска отображаются в виде элемента дерева групп и могут быть слиты с любой группой изображений.
  • В файле фотоальбома сохраняются относительные пути к файлам изображений, поэтому их можно перемещать в любое место, сохраняя неизменным взаимное расположение фотоальбома относительно изображений. Однако в случае, если файл фотоальбома сохранён на другом диске или в сети (или наоборот, изображения находятся на сетевом компьютере, а фотоальбом на локальном), то в фотоальбоме сохраняются абсолютные пути, и тогда его расположение относительно этих изображений не имеет значения.
  • В режиме обзора программа отображает всплывающие описания эскизов. Содержимое этих описаний настраивается.
  • PhoA имеет функции сортировки изображений в выбранной группе или во всём фотоальбоме. Критерии сортировки включают практически все доступные данные, набор для сортировки может состоять из любого количества критериев; последний использованный набор запоминается.
  • Реализованы представления: уникальная технология работы с изображениями в режиме обзора. Вы можете без каких-либо особенных усилий классифицировать изображения, сваленные в общую кучу, по папкам. Единственное условие — свойства изображения должны быть соответствующим образом заполнены. Эти свойства используются для группировки изображений в папки в виде дерева. Возможные варианты группировки изображений: по пути к файлу, по датам и времени в различных вариантах, по месту, ключевым словам и др. Группировки могут быть каскадными, т.е. применяться одна после другой, количество их ограничено только здравым смыслом. Результат группировки (дерево папок вместе с соответствующими изображениями) можно поместить в любую группу фотоальбома, после чего можно доделать полученную ветку по вкусу, как обычно.
  • PhoA обеспечивает просмотр изображений (оконный/полноэкранный режимы), а также удобное отображение их описаний при просмотре. Параметры отображения можно изменить в настройках программы; есть функции просмотра слайдов, масштабирования (увеличения и уменьшения изображения, причём поддерживаются несколько вариантов ресэмплинга) и позиционирования изображения мышью/клавишами. Декодирование изображений осуществляется параллельным потоком и может производиться в фоновом режиме, параллельно с просмотром другого изображения. Также есть функция кэширования предыдущего просмотренного изображения.
  • Программа поддерживает работу с буфером обмена: Вы можете скопировать или вырезать выделенные изображения в буфер, а потом вставить их в другую группу или даже перенести в другой фотоальбом; также можно вставить файлы в Проводнике или список файлов в текстовом редакторе.
  • Имеется полнофункциональная система отката (undo): любая неверная операция может быть отменена (то же сразу для группы операций). Количество запоминаемых операций также устанавливается в настройках.
  • Программа позволяет выполнять несколько видов операций с файлами: копирование, перемещение, удаление и др. В частности, имеется встроенный механизм для подготовки фотоальбома (или представления, или любой их части) для записи на CD, DVD или другой сменный носитель.
  • В наличии имеются также прочие сервисные функции (статистика, операции между группами и т. д.)
  • PhoA имеет приятный внешний вид, обходительные манеры и удобный русскоязычный интерфейс. Что ещё нужно правильному пользователю?

Примечание. Формат файла фотоальбома (.phoa) иногда меняется параллельно с развитием программы. Я буду и впредь предпринимать все усилия, чтобы сохранить совместимость "сверху вниз", то есть новые версии программы смогут открывать (и даже сохранять) файлы более старых версий.

Дальше >>


Системные требования

Для установки программы необходимо наличие операционной системы, немного места на диске и чуть-чуть оперативной памяти. Если говорить точнее, то PhoA запускается в среде Windows 95/98/ME/NT/2000/XP, занимает около 2 МБ дискового пространства и требует не менее 16 МБ установленной оперативной памяти. Поскольку в данной версии при открытии фотоальбома он целиком загружается в память, при больших количествах изображений (1000+) желательно наличие адекватного объёма памяти (32-64 МБ для Windows 95/98/ME/NT, 128 МБ для Windows 2000 и XP).

Дальше >>


Данные изображений

Текущая версия PhoA позволяет сохранять, просматривать и изменять (если поле редактируемое) следующие данные для каждого изображения. Кроме того, если поле помечено как поисковое, Вы можете производить поиск по данным этого поля.
Наименование | Тип данных | Редактируемое | Поисковое | Описание
ID | Натуральное число | Нет | Да | Уникальный внутренний идентификатор изображения. В фотоальбоме однозначно сопоставлен с именем файла. Используется для идентификации изображения, а также для создания ссылок.
Имя файла изображения | Строка-имя файла | Нет | Да | Имя файла изображения (без пути)
Полное имя файла изображения | Строка-имя файла | Нет | Нет | Имя файла изображения вместе с путём. Полное имя файла изображения уникально среди всех изображений фотоальбома.
Путь к файлу изображения | Строка | Нет | Да | Часть полного имени файла изображения, представляющая собой путь к этому файлу.
Размер файла изображения | Строка | Нет | Нет | "Человекочитаемое" представление размера файла изображения, например, 212,45 Кбайт или 839 байт.
Размер файла изображения в байтах | Целое число | Нет | Да | Целочисленное представление размера файла изображения, выраженное в байтах, например, 678233.
Ширина изображения | Целое число | Нет | Да | Ширина изображения, выраженная в пикселах.
Высота изображения | Целое число | Нет | Да | Высота изображения, выраженная в пикселах.
Размеры изображения | Размеры | Нет | Нет | Размеры изображения в пикселах в виде Ширина x Высота, например, 1024x768.
Ширина изображения эскиза | Целое число | Нет | Да | Ширина изображения эскиза, выраженная в пикселах.
Высота изображения эскиза | Целое число | Нет | Да | Высота изображения эскиза, выраженная в пикселах.
Размеры изображения эскиза | Размеры | Нет | Нет | Размеры изображения эскиза в пикселах в виде Ширина x Высота, например, 150x150.
Формат изображения | Пиксельный формат | Нет | Нет | Пиксельный формат изображения, например, 1 бит (монохромное) или Определяется устройством.
Дата | Дата | Да | Да | Дата событий на изображении, в диапазоне от 1 января 0001 г. до 31 декабря 9999 г. (вот бы дожить). Даты до нашей эры не поддерживаются (и после нашей, кстати, тоже).
Время | Время | Да | Да | Время событий на изображении, в диапазоне от 00:00:01 (значение, равное 00:00:00, считается отсутствием значения) до 23:59:59.
Место | Строка | Да | Да | Место, запечатлённое на изображении.
Номер или название плёнки | Строка | Да | Да | Если изображение снято плёночным фотоаппаратом, номер плёнки, содержащей изображение, присвоенный ей при проявке (обычно уникален), или присвоенное Вами название плёнки.
Номер кадра | Строка | Да | Да | Если изображение снято плёночным фотоаппаратом, номер кадра изображения, например, 20 или 4A.
Автор | Строка | Да | Да | Имя автора изображения или фотографа, сделавшего снимок.
Наименование или код носителя | Строка | Да | Да | Название носителя, на котором записан файл изображения (например, номер CD-ROM-диска).
Ключевые слова | Список строк | Да | Да | Список ключевых слов, связанных с изображением — например, люди или предметы на фотографии. Всегда отсортирован по алфавиту, сравнение ключевых слов всегда регистронезависимо.
Описание | Строка | Да | Да | Более-менее краткое описание событий на изображении, предназначенное для отображения при просмотре (это рекомендуемое назначение поля).
Примечания | Строка | Да | Да | Любые данные, не попавшие в остальные поля.
Поворот | Угол | Да | Нет | Угол поворота изображения при просмотре. Подробнее см. Преобразования.
Отражения | Набор флагов | Да | Нет | Набор флагов отражения изображения при просмотре: [горизонтальное, вертикальное]. Подробнее см. Преобразования.

См. также:

Режим обзора
Работа в режиме обзора
Поиск изображений
Окно свойств изображений


История версий

Этот документ суммирует отличия между версиями PhoA в обратном хронологическом порядке.

Различия версий файла фотоальбома

Версии программы

PhoA 1.1.9
[21.01.2005]
  • Разрешено создавать представления без группировок - например, содержащие только выражение фильтра.
  • Прочие исправления (подробности на сайте — в Mantis Issue Tracker).
PhoA 1.1.8 beta
[31.12.2004]
  • Долгожданная возможность смены файла изображения: страница Свойства файла диалога свойств изображений.
  • Начальная поддержка формата DNG (Digital Negative) от Adobe.
  • Отказоустойчивое сохранение файла фотоальбома.
  • Оптимизирован поиск и удаление неиспользуемых изображений, благодаря чему удаление групп и изображений теперь происходит существенно быстрее.
  • Прочие исправления (подробности на сайте — в Mantis Issue Tracker).
PhoA 1.1.7 beta
[07.12.2004]
  • Возможность подключения библиотеки быстрого JPEG-декодирования IJL (Intel JPEG Library) в качестве plugin-модуля. При наличии модуля ijl15.dll в каталоге Plugins программа автоматически использует его для декодирования файлов JPEG, что даёт прирост в скорости до 300%.
  • Сильно оптимизировано чтение эскизов, что в совокупности с использованием IJL даёт просто сумасшедшую скорость их построения.
  • Andrew Dudko написал начальную версию компилятора выражений; благодаря этому поиск изображений теперь можно производить по выражениям, написанным по специальным правилам.
  • То же самое выражение теперь можно использовать для фильтрации представлений.
  • Прежний вариант поиска также остался (теперь он называется Простой поиск), появилась возможность добавления произвольного количества критериев по любым свойствам изображений.
  • Новые поисковые/отображаемые свойства изображений: ширина эскиза, высота эскиза, размеры эскиза.
  • Возможность просмотра изображения в Мастере добавления изображений: как на странице выбора, так и на странице отметки файлов.
  • Ctrl+Правый клик на странице Просмотр и настройка диалога свойств изображений также вызывает системное контектное меню.
  • Прочие исправления (подробности на сайте — в Mantis Issue Tracker).
PhoA 1.1.6 beta
[09.11.2004]
  • Полностью переделан механизм локализации интерфейса программы. Теперь для подключения нового языка интерфейса достаточно поместить файл перевода в каталог языковых файлов. Сам файл перевода является обычным текстовым файлом, доступным для редактирования любым текстовым редактором; однако настоятельно рекомендуется выполнять перевод с помощью программы DKLang Translation Editor (доступной на сайте), предоставляющей множество сервисных функций, таких, как синхронизация записей с исходным файлом, отображение исходных записей на другом языке и автоматический перевод с использованием Репозитория переводов.
  • Примерно на 80% изменена внутренняя архитектура программы, что не может не сказаться на количестве глюков ;)
  • Сохранение данных отката теперь происходит на диск, а не в память. Это позволило увеличить количество операций в буфере по умолчанию.
  • Окно эскизов: плавная прокрутка; Ctrl+Стрелки/PgUp/PgDn/Home/End теперь сдвигают фокус, не меняя выделения; Shift+Alt+Стрелки/PgUp/PgDn/Home/End создают прямоугольное выделение; Пробел/Ctrl+Пробел переключает выделение текущего эскиза; Ctrl+колёсико мыши прокручивает на целый экран за щелчок.
  • Возможность добавления файлов изображений путём перетаскивания в дерево групп.
  • Новые фильтры ресэмплинга: Draft (качественнее, чем Nearest neighbor, но существенно быстрее Bilinear/Bicubic) и Cosine.
  • Дополнительные настройки внешнего вида эскизов: стиль и цвет рамки фона.
  • Возможность выбора страницы по умолчанию для диалога свойств изображений.
  • Возможность редактирования данных изображений при отображении представления.
  • Кэширование эскизов при обзоре больше не используется. Как выяснилось, оно создавало большие проблемы под Win9x.
  • Нажатие клавиши Enter в режиме обзора, когда активно окно эскизов, запускает просмотр текущего изображения. Нажатие Shift+Ctrl+Enter запускает просмотр с включенным показом слайдов.
  • Нажатие клавиши Enter в режиме просмотра приводит к возврату в режим обзора, но текущим изображением в окне просмотра эскизов становится последнее просмотренное.
  • Множество мелких исправлений.
PhoA 1.1.5 beta
[14.06.2004]
  • Возможность недеструктивного (не изменяющего файлы изображений) поворота изображений на угол, кратный 90°, а также отражения их по горизонтали и вертикали, при просмотре. Также указанные преобразования могут быть сохранены вместе с изображением в файле фотоальбома. Команды преобразований на странице Просмотр (ныне Просмотр и настройка диалога свойств изображений.
  • Новые свойства групп изображений: ID (уникальный числовой идентификатор), текстовое описание, количество изображений и вложенных групп; соответствующий диалог свойств группы; возможность настройки и отображения подсказок.
  • Усовершенствованы диалоги сообщений: там, где это доступно, имеется переключатель Больше не показывать данное сообщение.
  • Возможность выбора визуальной темы для панелей инструментов и строки состояния.
  • Нажатие Ctrl+Enter в диалогах срабатывает как нажатие кнопки OK. Это позволяет применять изменения, когда курсор находится в многострочном поле ввода.
  • Возможность автозаполнения преобразований изображения (поворота и отражений) согласно метаданным.
  • Мастер операций с файлами: в запросе на перезапись файла дополнительно появились кнопки Да для всех и Нет для всех.
  • Отображение заставки при запуске и статуса загрузки.
  • Опции анимации скрытия заставки и диалога О программе.
  • Поддержка ключей командной строки.
  • Команда меню Вид | Убрать результаты поиска.
  • Расширенная поддержка TIFF.
  • Мелкие изменения и исправления.
PhoA 1.1.4 beta
[16.05.2004]
  • Мастер файловых операций: опции выбора изображений с существующими/несуществующими файлами на странице выбора изображений для операции.
  • Усовершенствованы маски файлов: символ ! в начале маски инвертирует её значение.
  • Нажатие на эскизе правой кнопки мыши при нажатом Ctrl в режиме обзора вызывает системное контекстное меню для текущего файла изображения. То же самое для нажатия правой кнопки мыши с Ctrl в режиме просмотра.
  • Окно просмотра с опцией Поверх всех окон теперь не закрывает окна свойств изображения и окна настроек.
  • Настройки программы теперь используют редактирование "на месте" (inplace). Так, отображаемые на эскизах свойства изображений выбираются из выпадающего списка.
  • Опции режима обзора Цвет фона эскиза и Цвет шрифта эскиза.
  • Опция режима просмотра Удерживать курсор мыши над кнопкой панели инструментов.
  • Опция режима просмотра Отображать информацию об изображении и команда Отображать информацию при просмотре.
  • Опция Мастера добавления изображений Отображать скрытые файлы и папки.
  • Страница протокола в мастерах отображает порядковый номер записи, общее количество записей и ошибок. Также появились функции копирования записи в буфер обмена и поиска строки.
  • Опции буфера обмена позволяют задать, какие данные в него помещают операции Копировать и Вырезать. Возможные форматы: изображения PhoA, объекты "Файл" (это позволяет легко копировать файлы для выделенных изображений в любой каталог), список путей файлов, изображение эскиза.
  • Добавлена возможность вызова внешних программ-инструментов: страница Инструменты в диалоге настроек; возможность встраивания дополнительных пунктов в меню Сервис и контекстные меню.
  • Исправлен вызов справки в диалогах по клавише F1.
  • Исправлена ошибка Access Violation при наличии изображений в корневой группе и выборе пункта меню Файл | Новый.
  • Исправлены ошибки отображения размеров более 2 Гб в Статистике.
  • Новые изображения кнопок, пунктов меню и т.д.
  • Немного реорганизована документация.
PhoA 1.1.3 beta
[29.03.2004]
  • Новый язык интерфейса: украинский (перевод Сергея Микулина).
  • Добавлен Мастер файловых операций, позволяющий производить следующие операции с файлами изображений:
    • Копирование файлов выбранных изображений в единственную папку / с сохранением иерархии исходных папок относительно заданного пути / с сохранением иерархии групп изображений относительно заданной группы (с возможностью создания нескольких копий одного файла, если изображение находится в нескольких группах одновременно).
    • Перемещение файлов выбранных изображений — с теми же опциями, что и копирование; при этом программа обновляет ссылки на файлы в соответствующих изображениях. Имеется опция удаления оригинальных файлов совсем или в Корзину.
    • Удаление файлов выбранных изображений, естественно, вместе с изображениями.
    • Перестройка эскизов выбранных изображений — эта операция теперь также производится с помощью Мастера.
    Кроме того, при копировании и перемещении файлов есть опции автоматического создания отдельного фотоальбома для копируемых/перемещаемых файлов, копирования программы и создания файла автозапуска autorun.inf — это позволяет без труда подготовить фотоальбом для записи на CD или DVD.
  • Возможность сохранения и загрузки настроек в/из ini-файла. Опция загрузки настроек из файла phoa.ini (при запуске программы), если он присутствует в её каталоге.
  • Ускорено отображение окна Операции с изображениями.
  • Запоминание настроек в Мастере добавления изображений.
  • Настройка перетаскивания панелей инструментов влияет также на панель в режиме просмотра.
  • Возможность сортировки результатов поиска.
  • Мелкие исправления.
PhoA 1.1.2
[07.02.2004]
  • Новые языки интерфейса: German (перевод Dominik Mayer) и Brazilian Portuguese (перевод Cesar Boschetti).
  • Понижен приоритет фонового декодирующего потока. Благодаря этому существенно быстрее отображается уже готовое изображение.
  • Устранена злостная утечка памяти — фоновый поток не завершался при выходе из режима просмотра.
  • Исправлены ошибки при поиске по размерам изображения. Маска имени файла теперь ищет именно по имени файла, а не по полному пути.
PhoA 1.1.1b
[17.09.2003]
  • Новые опции Поиск при наборе текста и Задержка сброса набора для поиска в настройках деревьев/списков.
  • В диалоге Свойства изображений фокусируется первый элемент на странице.
  • Изменения на странице Свойства изображений | Метаданные: панель описания, вывод кода метатега.
  • Изменения на странице Свойства изображений | Просмотр: исправлено масштабирование колёсиком мыши.
  • Изменения на странице Свойства изображений | Ключевые слова: переключатель Только отмеченные; новые ключевые красятся в синий цвет только при отсутствии выделения.
  • Изменения на странице Свойства изображений | Группы: ускорено первое отображение страницы.
  • Сделана попытка исправить отображение шрифтов и в Unicode-, и в не-Unicode-системах для разных кодовых страниц/наборов символов.
  • Изменены диалоги, исправлено отображение в системах, где используются крупные шрифты.
  • Немного расширен список EXIF-метатегов, добавлены описания ко многим тегам.
  • Введена поддержка "нестандартных" метатегов: Unicode (WinXP-тегов), версий и т.д.
  • Исправлена ошибка загрузки, проявлявшаяся в отказе PhoA читать фотоальбомы версии 0.x.
  • Исправлена ошибка при просмотре: предекодирование не работало.
  • Исправлена ошибка при поиске: неверно работал поиск по дате, времени и ключевым словам.
  • Устранена некоторая утечка памяти, возникавшая в процессе работы.
PhoA 1.1.1a
[08.09.2003]
  • Изменён формат файла фотоальбома — теперь он весьма расширяем и предполагается, что будет меняться не так часто.
  • Немного изменён вид и работа с деревом папок:
    • Убрана панель инструментов "Представления", вместо неё появилась кнопка быстрого вызова меню представлений рядом с узлом фотоальбома.
    • Изображения можно складывать непосредственно в узел фотоальбома, даже не создавая ни одной группы.
    • Рядом с именем группы-папки отображается количество изображений в группе.
    • Изменён принцип работы механизма Drag'n'Drop: для вставки узла "братом" другого узла (выше или ниже), необходимо перетащить узел на свободное место, при этом место вставки отображается горизонтальной линией. Чтобы сделать узел "ребёнком" другого узла, его нужно перетащить непосредственно на этот узел, при этом подсвечивается сам целевой узел. Кнопка Shift ушла в историю (в смысле, в дереве папок ;)
    • При перетаскивании группы или изображений на узел группы-папки этот узел раскрывается, если задержать на нём мышь на некоторое время. Также при остановке мыши вблизи верхней или нижней границы окна групп (при перетаскивании) дерево групп начинает прокручиваться.
    • Косметические изменения (корневые элементы выделяются жирным шрифтом, при Drag'n'Drop перетаскивается "фантомное" изображение папок и т.д.)
    • Списки можно настраивать.
  • Полностью разделены процессы добавления и редактирования изображений. Сделано это с целью убрать компромиссные решения в интерфейсе программы. Изображения добавляются всегда с параметрами по умолчанию, потом при желании можно заполнить их данные.
  • Изменения в окне добавления изображений:
    • Окно выполнено в виде мастера, при этом на первом этапе выбираются файлы и/или папки с изображениями, на втором можно выбрать уже индивидуальные файлы.
    • При выборе изображений можно отфильтровать их по наличию/отсутствию в фотоальбоме, по формату и дате/времени модификации файла.
    • Добавление изображений производится в отдельном потоке, что улучшило реакцию интерфейса на действия пользователя. Процесс добавления может быть временно приостановлен.
    • Процесс добавления протоколируется, протокол может быть сохранён в файл.
  • Полнофункциональная поддержка спецификации метаданных JPEG-изображений EXIF 2.1 — сведений, помещаемых в изображения практически любой цифровой камерой, а также современными графическими редакторами. Метаданные могут быть использованы для заполнения отдельных полей данных изображения.
  • В окне свойств изображений изменений столько, что проще показать, чем рассказать :). Кратко:
    • Диалог стал многостраничным.
    • Страница Свойства файла позволяет просмотреть информацию о файлах, предоставляемую Windows.
    • Страница Метаданные отображает все данные EXIF, содержащиеся в файлах JPEG.
    • Страница Просмотр даёт возможность просмотреть любой из выбранных файлов в выбранном масштабе.
    • Страница Данные — это, собственно, то, что и было раньше диалогом свойств изображения + возможность ввода новых данных.
    • Страница Ключевые слова позволяет изменять список ключевых слов добавляя, удаляя или изменяя заданное слово во всех выбранных изображениях.
    • Страница Группы отображает список групп фотоальбома, и помечает те, к которым принадлежат выбранные изображения. Можно внести эти изображения в группу или удалить их из группы, поставив или сняв отметку с её имени.
  • Сильно расширены настройки программы.
  • Можно переставлять изображения внутри группы с помощью Drag'n'Drop (в окне просмотра эскизов). Ранее порядок можно было изменить только сортировкой.
  • Представления теперь поддерживают автоматическую сортировку изображений в группе.
  • В окне просмотра эскизов всегда по возможности выделяется первый эскиз.
  • Убрано окно истории операций: требуемое количество операций может быть отменено непосредственным выбором из списка кнопки Отменить на панели инструментов или через подменю Правка | История изменений.
  • Изменены все прочие деревья, отображавшие список групп. Их вид приведён в соответствие главному дереву.
  • В строке состояния (status bar) отображается общее количество различных изображений в фотоальбоме.
  • В режиме просмотра отображается локальная панель инструментов.
  • Панели инструментов и окно просмотра эскизов в Windows XP и более поздних имеют более XP-шный вид.
  • Моря исправлений, океаны мелких изменений, горстка новых багов.
PhoA 1.0.2a
[02.06.2003]
  • По многочисленным жалобам на качество эскизов введена фильтрация при ресэмплинге для устранения "мохнатости" (fuzziness) уменьшенного изображения. Возможные варианты фильтрации: Nearest Neighbor, Linear, B-spline (бикубическая), Lanczos, Mitchell. В качестве побочного эффекта, вследствие сглаживания картинки эскиза, размер эскизов (так как используется JPEG-сжатие) уменьшается на 10-25% (так, при использовании B-сплайн-интерполяции уменьшение составляет 20-25%).
  • Значительно увеличена скорость масштабирования и прокрутки изображения. При просмотре можно также применять любой из вышеперечисленных фильтров.
  • Добавлена опция декодирования изображений в фоновом режиме: отдельный поток декодирует следующее изображение, пока Вы просматриваете текущее. В таком варианте время перехода к следующему изображению минимально (но требует больше памяти).
  • Добавлена опция кэширования просмотренного изображения, что минимизирует время возврата к предыдущему изображению (также требует больше памяти).
  • По ошибке поддержка формата .gif не была включена. Исправлено.
  • Добавлена поддержка форматов .msk (Paint Shop Pro mask), .tub (Paint Shop Pro picture tube), .pfr (Paint Shop Pro picture frame).
  • Кардинально изменен вывод информации при просмотре. Теперь информация всегда выводится поверх изображения, опционально на полупрозрачном фоне, есть режим визуального позиционирования блока информации.
  • В системах с несколькими мониторами диалоговые окна открывались в неподходящих местах. Исправлено.
PhoA 1.0.1a
[17.05.2003]

Огромное множество изменений, что отражается в номере версии и времени, затраченном на её создание.

  • Представления! [начинается... :] Принципиально новый алгоритм работы с изображениями в режиме обзора. Теперь Вы можете без каких-либо особенных усилий классифицировать изображения, сваленные в общую кучу, по папкам. Единственное условие — свойства изображения должны быть соответствующим образом заполнены. Возможные варианты группировки изображений: по пути к файлу, по датам в различных вариантах, по месту, ключевым словам и др. Группировки могут быть каскадными, т.е. применяться одна после другой, количество их ограничено только здравым смыслом. Результат группировки (дерево папок вместе с соответствующими изображениями) можно поместить в любую группу фотоальбома, после чего можно доделать полученную ветку по вкусу, как обычно.
  • Изменён формат файла фотоальбома (.phoa). Файлы фотоальбомов, начиная с версии 1.0.1a, содержат данные о представлениях, и это делает их несовместимыми с более старыми версиями PhoA. Программа поддерживает сохранение также и в файлы формата PhoA 0.x, что выбирается при сохранении файла (Файл | Сохранить как...), соответственно, представления при этом не сохраняются.
  • Сортировка теперь может состоять из любого количества критериев, и она построена аналогично группировкам в представлении. Список признаков для сортировки теперь существенно расширен.
  • Всплывающие описания эскизов в режиме просмотра теперь можно настраивать, выбирая, какие именно данные в них приводятся.
  • Информация об изображении, отображаемая в режиме просмотра, теперь тоже пополнилась дополнительными вариантами выбора.
  • Три варианта размеров кнопок панели инструментов (мелкие/средние/крупные).
  • Глобально расширена поддержка форматов. Теперь поддерживается почти всё, что можно (кратко: Windows bitmap (BMP, RLE, DIB), OS/2 bitmap, TIFF, GFI fax, SGI, Autodesk, Truevision Targa, ZSoft Paintbrush, Word 5.x, Kodak Photo-CD, Portable pixel/gray map, Dr. Halo CUT, CompuServe GIF, SGI Wavefront, Photoshop, Paint Shop Pro, Portable network graphic PNG)
  • Новые алгоритмы работы с ключевыми словами (ключевые слова, содержащие пробелы и запятые, должны браться в кавычки; при выборе из списка такие ключевые слова берутся в кавычки автоматически; убрано преобразование ключевых слов в нижний регистр при построении их списка, но сравнение ключевых слов по-прежнему регистронезависимо).
  • Куча мелких исправлений (в т.ч. исправлен Access Violation в некоторых случаях в режиме обзора).
PhoA 0.10 beta
[01.09.2003]
  • PhoA теперь имеет полностью функциональную систему отката (undo).
  • Сделана кнопка Добавить все в Окне добавления изображения, позволяющая произвести добавление в группу всех выбранных файлов изображений без запроса пользователя (с параметрами по умолчанию).
  • Добавлена работа с буфером обмена (вырезать, копировать, вставить).
  • Мелкие исправления (режим обзора; статистика фотоальбома).
PhoA 0.03
[20.10.2002]
  • Полностью двуязычная версия (русский и английский языки), в том числе Программа установки и файлы Справочной Системы.
  • Реализован режим Показа слайдов.
  • Мелкие исправления.
PhoA 0.02b
[06.09.2002]
  • Первый общедоступный релиз программы.

Различия версий файла фотоальбома

Формат файла фотоальбома (.phoa) иногда меняется параллельно с развитием программы. Разные версии файла фотоальбома отличаются в наборе сохраняемых данных. Нижеприведённая таблица разъясняет различия в форматах файла фотоальбома.
Версия программы Внутренний номер
версии формата 		Наименование формата Новые возможности сравнительно с предыдущими версиями
PhoA 1.1.7 beta 0003 PhoA 1.1+ Новое свойство представления:
  • Выражение фильтра изображений.
PhoA 1.1.5 beta 0003 PhoA 1.1+ Новые свойства изображения:
  • Поворот изображения.
  • Отражения изображения.
Новые свойства группы:
  • ID группы.
  • Описание группы.
PhoA 1.1.1a 0003 PhoA 1.1+ Новые свойства изображения:
  • Ширина изображения.
  • Высота изображения.
  • Время изображения.
  • Автор изображения.
  • Наименование/код носителя файла изображения.
  • Примечание изображения.
Представления:
  • Новые свойства группировки представлений: час времени, минута времени, автор, носитель.
  • Возможность задания сортировки.
PhoA 1.0.1a 0002 PhoA 1.0.x Представления:
  • Список представлений.
  • Наименование представления.
  • Список групировок представления.
PhoA 0.02b 0001 PhoA 0.x Первый релиз программы.

См. также:

Форматы файлов


Лицензионное соглашение

Это Пользовательское Лицензионное Соглашение (Соглашение) является официальным правоустанавливающим документом, регулирующим отношения между вами (физическим или юридическим лицом) и автором данного ПО (DK Software), относительно Программного Пакета PhoA, включающего компьютерные программы, и могущего содержать дополнительные носители, печатные материалы и онлайн-, или электронную документацию (Программный Продукт).

Устанавливая, копируя или другим способом используя Программный Продукт, вы тем самым соглашаетесь выполнять условия данного Соглашения. В случае, если вы не принимаете условий данного Соглашения, не устанавливайте и не используйте этот Программный Продукт.

Лицензия на Программный Продукт

Все версии Программного Продукта защищены законами об авторском праве и нормами международного права в сфере охраны авторских прав, а также прочими законами и положениями об охране интеллектуальной собственности.

Исключительные права на Программный Продукт принадлежат DK Software. Программный Продукт не может быть скопирован, продан, распространён или использован никаким способом, не описанным в данном документе без получения предварительного письменного согласия на это со стороны DK Software.

Стороны, заинтересованные в лицензировании Программного Продукта для иных, чем персональное использование, целей, должны связаться с DK Software по следующему адресу: phoa@narod.ru.

  1. Предмет лицензирования
    Данное Соглашение предоставляет вам следующие права: Установка и Использование. Вам разрешается устанавливать и использовать неограниченное количество экземпляров Программного Продукта.

    Копирование и распространение
    Вам разрешается копировать и распространять неограниченное количество экземпляров Программного Продукта, при условии, что каждый экземпляр является подлинной и полной копией оригинального продукта, включая все указания об авторских правах и торговых марках, а также что он сопровождается копией данного Соглашения. Не допускается включать Программный Продукт в состав никаких бесплатных, условно-бесплатных или коммерческих пакетов или продуктов.
  2. Прочие права и ограничения
    Ограничение на вскрытие технологии, декомпиляцию, дизассемблирование и модификацию ресурсов, входящих в Программный Продукт. Не допускается производить вскрытие технологии, декомпиляцию, дизассемблирование Программного Продукта, кроме и только в случаях, когда такие действия допускаются действующим законодательством вопреки данному ограничению.

    Разделение компонентов
    Программный Продукт лицензируется только как целостный продукт. Не позволяется отделять от него части или компоненты для использования более, чем на одном компьютере.

    Передача программного обеспечения
    Вы можете осуществить передачу всех своих прав по данному Соглашению при условии, что принимающая сторона согласна со всеми условиями этого Соглашения.

    Отказ от Соглашения
    DK Software может в одностороннем порядке отказаться от выполнения условий Соглашения без ущерба для прочих своих прав в случае, если вы нарушаете пункты или условия этого Соглашения. В таком случае вы обязаны уничтожить все экземпляры Программного Продукта, а также все его компоненты и части.
  3. Авторское право
    Если обратное не указано явно, все наименования и авторские права, относящиеся к Программному Продукту (включая любые изображения, фотографии, мультипликации, видео- и аудиоматериалы, тексты и аплеты, включённые в состав Программного Продукта), права на сопровождающую печатную документацию, а также на любые копии Программного Продукта, принадлежат DK Software. Программный Продукт защищён законами об авторском праве, а также международными соглашениями. Поэтому вы обязаны обращаться с Программным Продуктом так же, как и с любым другим защищённым авторским правом материалом.

Ограниченная гарантия

Отсутствие гарантий

DK Software явно отрицает любые гарантии касательно Программного Продукта. Программный Продукт, а также вся сопроводительная документация поставляются по принципу as is ("как есть") без каких-либо явных или подразумеваемых гарантий, включая, без ограничений, подразумеваемые гарантии продаваемости, пригодности для конкретной цели или безопасности. Вы можете использовать Программный Продукт исключительно на свой страх и риск.

Отсутствие ответственности за повреждения

Ни при каких обстоятельствах автор данного Программного Продукта не может нести ответственности ни за какие особые, закономерные, случайные или косвенные повреждения (включая, без ограничения, повреждения, связанные с потерей прибыли, создания препятствий бизнесу, потерей деловой информации или любой другой материальной потерей), возникшие вследствие использования или невозможности использования данного продукта, даже в случае, если DK Software была уведомлена о возможности таких повреждений или произошедших из-за известных дефектов.

Регистрация

PhoA является продуктом класса "donationware" (т. е. существующим в том числе и благодаря пожертвованиям). Он может быть использован без какой-либо оплаты для любой цели. Мы предлагаем делать пожертвования на нашем сайте, если вы можете себе это позволить. Посетите сайт http://www.dk-soft.org, чтобы получить дополнительную информацию.

Используя данное программное обеспечение, вы соглашаетесь с условиями данного соглашения.

Благодарности

  • Jordan Russel — TB2000 & InnoSetup
  • Alex Denisov — TBX & Graphics32
  • Mike Lischke — VirtualTree & GraphicEx
  • Jim Kueneman — VirtualShellTools
  • Frank Händle — хостинг

    • Авторское право ©2002-2005 DK Software. Все права сохранены.


Режимы работы программы

Программа PhoA имеет два основных режима работы:

  • обзор и упорядочивание изображений;
  • просмотр изображений.


Режим обзора

Как уже было сказано, режим обзора предназначен для создания фотоальбома. Этот режим является стартовым для программы — запускается PhoA именно в этом режиме.

Главное окно программы построено по принципу стандартного Проводника Windows: в левой части расположено дерево групп-папок, а в правой отображаются эскизы и описания изображений, находящихся в выбранной слева группе.

Слева у корневого узла дерева — узла фотоальбома расположена кнопка-меню, содержащая команды работы с представлениями фотоальбома и переключения отображения между представлениями и группами фотоальбома.

Вы также можете отображать это меню нажатием клавиши Пробел, когда корневой узел выделен.

См. также:

Описание команд меню
Работа в режиме обзора
Работа с представлениями


Описание команд меню в режиме обзора

  • Меню Файл
  • Меню Правка
  • Меню Вид
  • Меню Сервис
  • Меню Справка

Непосредственно слева от узла фотоальбома в дереве папок расположена кнопка, вызывающая меню представлений.

См. также:

Сочетания клавиш и управление мышью
Режим просмотра
Окно свойств фотоальбома


Режим обзора :: Меню "Файл"

В этом меню собраны команды работы с файлами фотоальбомов.
Команда | Описание
Новый | Создание нового фотоальбома. При этом удаляются все группы, изображения и представления, а параметры фотоальбома приводятся к заданным по умолчанию.
Открыть... | Вызывает стандартный диалог открытия файла для выбора файла фотоальбома (с расширением .phoa).
Сохранить | Сохраняет фотоальбом в текущий открытый файл. Если это новый фотоальбом, при выборе этого пункта выполняется команда Сохранить как...
Сохранить как... | Вызывает стандартный диалог сохранения файла — для сохранения текущего фотоальбома в файл с другим именем.
Сохранить настройки в файл... | Отображает диалог для сохранения текущих настроек программы в файл с расширением .ini, подробнее.
Загрузить настройки из файла... | Отображает диалог для загрузки настроек программы из файла с расширением .ini, подробнее.
Выход | Запрашивает подтверждение в случае несохранённого фотоальбома (или если запрос подтверждения при выходе задан в настройках подтверждений) и завершает работу с программой.
Далее следуют пункты меню последних открывавшихся файлов (их количество настраивается с помощью общих настроек программы).


Режим обзора :: Меню "Правка"

В этом меню собраны команды для редактирования фотоальбома, а также для перехода в режим просмотра.
Команда | Описание
Отменить имя_операции | Отменяет изменения, сделанные вами при выполнении указанной (последней) операции.
История изменений | Предоставляет доступ к списку сделанных изменений, с помощью которого вы можете отменить несколько сделанных операций сразу.
Вырезать | Удаляет выделенные изображения в буфер обмена (вы можете впоследствии вставить их в другую группу).
Копировать | Копирует выделенные изображения в буфер обмена.
Вставить | Позволяет добавить изображения из буфера обмена в текущую группу, если они там есть. Естественно, добавляются только изображения, новые для текущей группы — совпадающие изображения отсеиваются. Если это указано в настройках программы, выводится уведомление о количестве реально вставленных изображений.
Добавить группу | Добавление новой группы. Новая папка группы создаётся в текущей выделенной папке. Если, соответственно, выделен узел фотоальбома, то группа будет создана в его корневом каталоге. По умолчанию группе даётся имя "Новая группа", которое нужно изменить и нажать клавишу Enter.
Добавить изображения... | Запускает Мастер добавления изображений, позволяющий произвести добавление изображений (т. е. файлов) в фотоальбом.
Удалить
  • Когда активно дерево групп — удаление группы.
  • Когда активно окно эскизов — удаление выделенных в нём изображений.
Изменить...
  • Когда выделен узел фотоальбома (корневой узел дерева при отображении дерева групп), выбором этого пункта для него можно ввести описание и изменить параметры эскизов в окне свойств фотоальбома.
  • Когда выделена одна из групп фотоальбома, выбором этого пункта её можно переименовать или ввести описание для неё. (Также переименовать группу можно нажав один раз на выделенном наименовании группы, или с помощью клавиши F2. Для отмены редактирования нужно нажать клавишу Esc, для сохранения нового имени группы — клавишу Enter).
  • Когда выделен узел представления (корневой узел дерева при отображении представления), с помощью этого пункта вы можете изменить его свойства.
  • Когда активно окно эскизов, этот пункт отображает окно свойств изображений, позволяющий просмотреть или изменить свойства выделенных изображений.
Сортировать изображения... | Предоставляет доступ к окну сортировки изображений для упорядочивания изображений группы или всех групп фотоальбома.
Выделить все | Выделяет все изображения текущей группы.
Снять выделение | Убирает выделение со всех изображений группы.
Просмотр | Служит для перехода в режим просмотра. Также в режим просмотра можно перейти, сделав двойной щелчок мышью на изображении, или нажав Enter, когда активно окно эскизов.
Просмотр слайдов | Запускает режим просмотра текущего изображения и включает режим показа слайдов.


Режим обзора :: Меню "Вид"

Это меню контролирует вид окна программы.
Команда | Описание
Панель инструментов | Управляет отображением основной панели инструментов.
Строка состояния | Управляет отображением строки состояния.
Рекурсивный просмотр | Когда включен режим рекурсивного просмотра, в окне просмотра эскизов отображаются эскизы не только из группы, выбранной в дереве, а также из всех её подгрупп. Переупорядочивание эскизов мышью в этом режиме допускается только если текущая группа не содержит подгрупп.
Убрать результаты поиска | Скрывает папку результатов поиска.
Далее следуют пункты для работы с представлениями фотоальбома.
Группы изображений | Служит для перехода к основному режиму просмотра дерева папок, когда в окне групп программы отображаются группы фотоальбома (режим по умолчанию).
Далее следуют пункты представлений фотоальбома. При выборе пункта активизируется соответствующее представление, и в дереве групп отображается автоматически сгенерированная программой иерархия его групп.
Новое представление... | Открывает окно свойств представления для создания нового представления.
Удалить представление | Удаляет текущее представление (если в данный момент активно именно представление).
Изменить представление... | Открывает окно свойств для редактирования текущего представления (если в данный момент активно именно представление).
Поместить в группу... | Вызывает диалоговое окно выбора группы фотоальбома, позволяющее создать копию папок представления в группах фотоальбома.


Режим обзора :: Меню "Сервис"

Здесь расположены дополнительные инструменты для работы с фотоальбомами.
Команда | Описание
Настройки программы... | Отображает окно настроек программы.
Статистика... | Подсчитывает и выводит различные сводные данные по фотоальбому.
Операции с изображениями... | Позволяет выполнять перемещение, копирование и другие операции с изображениями.
Операции с файлами изображений... | Запускает Мастер операций с файлами изображений, позволяющий скопировать, переместить, удалить файлы изображений, перестроить эскизы или восстановить повреждённые ссылки на файлы изображений.
Поиск... | Открывает окно поиска изображений. Более подробно о поиске рассказано здесь.


Режим обзора :: Меню "Справка"

Это меню содержит команды вызова Справочной системы PhoA и перехода на сайт программы.
Команда | Описание
О программе... | Вызывает окно с информацией о версии программы, об авторских правах и координатах для поиска обновлённых версий.
Содержание справки | Запускает Справочную систему PhoA, которую вы в данный момент и наблюдаете.
FAQ | Отображает раздел справки FAQ (часто задаваемые вопросы).
Интернет | Проверить обновление программы | Запускает Интернет-браузер по умолчанию и открывает в нём страницу проверки обновлений.
Интернет | Web-сайт программы | Запускает Интернет-браузер по умолчанию и открывает в нём домашнюю страницу PhoA.
Интернет | Поддержка программы | Запускает Интернет-браузер по умолчанию и открывает в нём страницу поддержки.
Интернет | Web-сайт DK Software | Запускает Интернет-браузер по умолчанию и открывает в нём страницу производителя программы.


Работа в режиме обзора

О наиболее общих задачах работы в режиме обзора упомянуто в рассказе о командах меню. Здесь я остановлюсь на более специфических вопросах работы с программой.

Данные изображений

Как уже было сказано в лирической части, программа хранит отдельно список изображений (точнее, список, элементы которого содержат ссылки на файлы изображений, эскизы, то есть уменьшенные копии исходных изображений, описания и т. д.). Как отдельный класс хранится дерево групп. Каждая отдельная группа содержит ссылки на этот список изображений, поэтому когда Вы добавляете к группе файл (а работа с изображениями всё равно ведётся на уровне файлов), который уже используется в фотоальбоме, программа сама подставляет все данные изображения; аналогично, если Вы изменяете какие-то данные изображения (например, место или дату), эти данные меняются и во всех вхождениях данного файла в группы фотоальбома.

Немного иначе работает этот принцип при удалении изображения из группы. Если на удаляемое изображение ссылается кроме текущей ещё и другая группа (или группы), то удаляется только ссылка на него, а само изображение продолжает "числиться" в фотоальбоме (ведь на него ссылаются другие группы); и если, скажем, вы будете потом добавлять этот файл опять, PhoA подставит все данные из найденного изображения. Если же это изображение присутствовало только в текущей группе, и оно удаляется — то оно будет стёрто из фотоальбома совсем, и при повторном добавлении Вам опять придётся вносить все данные этого изображения.

Drag'n'Drop

Естественно, одно изображение не может дважды входить в одну и ту же группу. Наиболее простой способ копирования изображений состоит в перетаскивании их мышью из правой части окна PhoA (эскизов) в левую (дерево папок), удерживая нажатой клавишу Ctrl. Если Вы перетаскиваете изображение без клавиши Ctrl, то изображение будет перемещено (удалено из исходной группы и помещено в группу назначения). Можно перетаскивать более, чем одно изображение одновременно: для этого перед началом перетаскивания нужно выделить все нужные изображения (с помощью клавиш Ctrl, Shift, Alt и нажатия левой кнопки/сдвига мыши) и начинать перетаскивание с любого из выделенных изображений. После завершения операции копирования/перемещения изображений PhoA выдаёт сводную информацию о сделанных изменениях, если это указано в Настройках программы (раздел Уведомления).

Помимо этого, можно перетаскиванием изменять структуру групп в их дереве. При перетаскивании группы на свободное пространство справа от узлов отображается место вставки группы в виде линии, при этом группа вставляется "братом" целевого узла, выше или ниже его, в зависимости от положения курсора мыши (также отражается на форме линии вставки). При перетаскивании группы поверх какого-либо узла, узел подсвечивается, и группа становится дочерним узлом подсвеченного узла.

NB: В корневом каталоге может находится только узел фотоальбома, обычные группы не могут быть вставлены рядом с ним.

Совершенно аналогичным образом можно копировать (перемещать тут нельзя) изображения из узла результатов поиска в любую группу. Поэтому удобно, например, после составления каталога фотографий по событиям, выбрать их по датам (например за год или за месяц) и организовать в папки по времени (или по месту).

Кроме всего вышеперечисленного, с помощью перетаскивания можно менять порядок следования изображений в группе: при перетаскивании выделенных эскизов внутри окна просмотра эскизов, также отображается место их вставки. Если отпустить кнопку мыши, все выделенные изображения переместятся в выбранное место в последовательности изображений, сохранив внутренний порядок (последовательность в которой они находились до перетаскивания). Альтернативный метод упорядочивания изображений — это их сортировка.

Буфер обмена

PhoA поддерживает работу с буфером обмена. На данный момент поддерживается работа со следующими форматами:
Наименование | Описание | Поддерживаемые операции
Изображения PhoA | Внутренний формат данных программы, поддерживающий все свойства изображений. | Копировать, Вырезать, Вставить
Файлы изображений | Формат объекта "файл" системы. Помещённые в буфер обмена файлы могут быть вставлены в обычную папку на диске в Проводнике или любой другой программе, поддерживающей работу с файлами. | Копировать, Вырезать
Пути файлов изображений | Простой текстовый список полных путей к файлам изображений. Список, помещённый в буфер обмена, может быть вставлен в любом текстовом редакторе. | Копировать, Вырезать
Эскиз | Обычный растровый рисунок (bitmap), представляющий собой текущий выбранный эскиз. Помещается в буфер обмена только в случае, когда выделено единственное изображение. Рисунок, помещённый в буфер обмена, может быть вставлен в любом графическом редакторе. | Копировать, Вырезать (только для единственного изображения)

Настроить форматы, помещаемые программой в буфер обмена, Вы можете в общих настройках программы.

Как следует из вышенарисованной таблицы, наиболее функциональным форматом является внутренний формат изображений PhoA. Он позволяет вырезать, копировать и вставлять любое количество изображений; данные, помещаемые в буфер, содержат всю информацию, касающуюся выделенных изображений, кроме их принадлежности группам. Это позволяет переносить (копировать) изображения в другую группу или даже в другой фотоальбом.

Есть одно ограничение, касающееся вставки изображений в другой фотоальбом: данные существующих (зарегистрированных в фотоальбоме с этим же именем файла) изображений не переписываются новыми; то есть при вставке, скажем, изображения, связанного с файлом C:\Photos\winter-vacation-1812.jpg, в фотоальбом, где этот файл уже зарегистрирован, это изображение просто будет добавлено в текущую группу (если его там ещё не было). В случае наличия вставляемого из буфера обмена изображения в целевой группе это изображение просто пропускается. По завершении вставки программа уведомляет Вас о количестве реально добавленных из буфера обмена изображений (контролируется Настройками программы — раздел Уведомления).

Система отката

В отличие от многих аналогов, PhoA имеет полнофункциональную систему отката (undo), позволяющую отменить результаты выполнения любой операции, изменившей данные фотоальбома (исключение составляют только операции с файлами изображений), а также серии операций — путём выбора команды меню Правка | Отменить или Правка | История изменений соответственно. При выборе пункта из списка истории изменений откатываются результаты всех предыдущих (расположенных выше по списку) операций.

Количество операций, которые можно отменить, задаётся в настройках программы. По умолчанию это значение равно 100.

Представления

Представления — это уникальная технология автоматической группировки изображений. Подробности — в разделе Работа с представлениями.

См. также:

Сочетания клавиш и управление мышью
Режим просмотра
Работа в режиме просмотра


Работа с представлениями

Введение

Представления фотоальбома выглядят аналогично дереву групп фотоальбома, с тем только отличием, что список групп Вы создаёте сами, а иерархия папок представления создаётся автоматически на основе данных изображений и указанных Вами группировок. Группировка является логической единицей организации представления, и она может формировать один или несколько уровней дерева папок. При построении иерархии папок представления каждое прошедшее через фильтр изображение попадает в какую-либо папку. В какую именно — это и определяется свойствами представления, их мы и рассмотрим более подробно далее.

Свойства представления

Как можно увидеть в окне свойств представления, представление имеет наименование, список группировок и список сортировок.
Наименование представления | Наименование задаётся Вами и может отражать содержимое представления, например, "По месту и дате".
Список группировок На списке группировок необходимо остановиться подробнее. PhoA поддерживает следующие виды группировок:
  • По пути к файлу изображения
    Изображения раскладываются по папкам согласно их физическому расположению на диске.
  • По году даты
    Изображения группируются в папки, каждая из которых содержит изображения с одинаковым годом. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку.
  • По месяцу даты
    Изображения группируются в папки, каждая из которых содержит изображения с одинаковым месяцем. Обычно имеет смысл применять эту группировку после группировки по году даты, тогда в папке каждого года будут папки с месяцами этого года; но эта группировка может применяться и независимо, в этом случае в папках будут находиться изображения с одинаковым месяцем, но разных годов. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку.
  • По дню даты
    Изображения группируются в папки, каждая из которых содержит изображения с одинаковым числом месяца. Обычно имеет смысл применять эту группировку после группировки по году даты и по месяцу даты, тогда в папке каждого года будут папки с месяцами этого года, а в них — папки с днями месяца; но эта группировка может применяться и независимо, в этом случае в папках будут находиться изображения с одинаковым числом, но разных годов и месяцев. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку.
  • По часу времени
    Изображения группируются в папки, каждая из которых содержит изображения с одинаковым часом (взятым из времени изображения). Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку.
  • По минуте времени
    Изображения группируются в папки, каждая из которых содержит изображения с одинаковой минутой (взятой из времени изображения). Обычно имеет смысл применять эту группировку после группировки по часу времени, тогда в папке каждого часа будут папки с минутами этого часа; но эта группировка может применяться и независимо, в этом случае в папках будут находиться изображения с одинаковой минутой, но разного часа. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку.
  • По месту
    Изображения организуются в папки по местам. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку.
  • По номеру плёнки
    Изображения заносятся в папки по номерам плёнок. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку.
  • По автору
    Изображения организуются в папки по авторам. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку.
  • По наименованию/коду носителя
    Изображения организуются в папки по наименованию/коду носителя. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку.
  • По ключевым словам
    Изображения организуются в папки по ключевым словам. Соответственно, одно изображение может находиться в нескольких папках, и оно будет в них находиться, если в нём указано несколько ключевых слов. Эта группировка поддерживает помещение неклассифицированных изображений в отдельную папку.
Список сортировок | После того, как изображения сгруппированы по папкам, они там расположены, как правило, хаотически, что не всегда приятно; тем более если учесть, что не существует способа повлиять на порядок следования изображений в группе представления. С целью устранить эту несправедливость в PhoA есть возможность отсортировать результаты группировки в каждой группе с помощью списка сортировок. Делается это в точности так же, как задаётся сортировка изображений в группах.

Помещение неклассифицированных изображений в отдельную папку

Как известно, Вы не обязаны заполнять все данные изображения, оставляя некоторые поля пустыми. Но в таком случае, поскольку при построении представления каждое изображение, прошедшее через фильтр, обрабатывается и присутствует в нём (см. выше), есть два варианта, как поступать с изображениями, не имеющими нужных сведений (даты при группировке по дате, места при группировке по месту и т.п.):

  • Если у конкретной группировки включен флажок "Неклассифицированные изображения в отдельной папке", то программа создаст соответствующую папку ("Без даты", "Без места") на том же уровне дерева, что и остальные папки, причём в самом начале уровня, и поместит туда такие изображения.
  • Если флажок не включен, то изображения без соответствующих данных останутся лежать в той же папке, что и были, никаких отдельных папок для них не создаётся. Если, скажем, после группировки по дате (с отключенным флажком) изображение так и осталось лежать в корневой папке (в папке, соответствующей самому представлению), то, если применить после этого группировку по месту (с включенным флажком), папка "Без места" будет создана в корневом каталоге, и изображение попадёт туда, а все остальные папки (с местами) будут созданы в папках дат; таким образом, классификация изображений по месту будет находиться на разных уровнях дерева папок.

Эта функция, естественно, неприменима при группировке по пути к файлу изображения, поскольку изображений без файлов, а файлов без путей не бывает (я таких, во всяком случае, не встречал).

Выражение фильтра изображений

Вы можете ограничить набор изображений, помещаемых в представление. Делается это с помощью редактора выражений фильтра аналогично Поиску по выражению. Если выражение фильтра не задано, в представление помещаются все изображения фотоальбома.

Копирование папок представления в фотоальбом

В PhoA есть возможность скопировать полученную структуру папок и изображений в виде обычных групп фотоальбома. Для этого нужно выбрать пункт меню Вид | Представления | Поместить в группу..., при этом появится окно выбора группы, в которую нужно поместить иерархию папок представления.

См. также:

Окно свойств представления
Режим обзора
Работа в режиме обзора
Сочетания клавиш и управление мышью
Работа в режиме просмотра


Автозаполнение свойств изображений

PhoA может автоматически заполнять некоторые свойства добавляемых изображений. На текущий момент возможности автозаполнения таковы:
Свойство Возможность автозаполнения
Дата
  • Из EXIF-тега Original date & time (оригинальные дата и время)
  • Из EXIF-тега Dititized date & time (дата и время оцифровки изображения)
  • Из EXIF-тега Date & time (дата и время последней модификации изображения)
  • Извлечение из имени файла — если имя файла в формате yyyy-mm-dd hh-mm-ss.*
  • Из даты/времени создания файла
  • Из даты/времени изменения файла
Время
  • Из EXIF-тега Original date & time (оригинальные дата и время)
  • Из EXIF-тега Dititized date & time (дата и время оцифровки изображения)
  • Из EXIF-тега Date & time (дата и время последней модификации изображения)
  • Извлечение из имени файла — если имя файла в формате yyyy-mm-dd hh-mm-ss.*
  • Из даты/времени создания файла
  • Из даты/времени изменения файла
Преобразования
(поворот, отражения)
  • Из EXIF-тега Orientation (ориентация, или положение изображения)

Программа пытается заполнить конкретное свойство изображения, перебирая разрешённые в настройках варианты в том порядке, в котором они перечислены. Если свойство было успешно заполнено, перебор на этом заканчивается.

Кроме того, на поведение автозаполнения влияет и опция Переписывать свойство, если оно уже указано.

См. также:

Настройки программы :: Диалоги
Данные изображений
Метаданные
Просмотр метаданных изображений Преобразования


Режим просмотра

Этот режим позволяет просматривать отдельные изображения — в отдельном окне или на полном экране. Это, собственно, и является целью того, ради чего стоит составлять фотоальбом.

В режиме просмотра доступны следующие функции:

  • масштабирование (увеличение и уменьшение) изображения;
  • прокрутка изображения мышью или клавишами, если оно не помещается целиком на экране;
  • переход к следующему, предыдущему, первому и последнему изображению в текущем списке просмотра;
  • переключение из оконного в полноэкранный режим и обратно;
  • изменение свойств текущего изображения;
  • включение/выключение режима показа слайдов;
  • вызов настроек программы и т. д.

Эти функции доступны через главное меню, кнопки панели инструментов, через контекстное меню, вызываемое нажатием правой кнопки мыши, а также используя команды клавиатуры и мыши.

См. также:

Работа в режиме просмотра
Настройки программы :: Режим просмотра
Режим обзора


Описание команд меню в режиме просмотра

  • Меню Изображение
  • Меню Вид
  • Меню Масштаб
  • Меню Сервис
  • Меню Справка
NB:
  • Большинство команд меню также доступно из контекстного меню режима просмотра, вызываемого нажатием правой кнопки мыши.
  • Нажатие правой кнопки мыши при удерживаемой клавише Ctrl вызывает системное контекстное меню (меню Проводника) для текущего файла изображения.
  • Если главное меню не отображается, чтобы показать его, выберите пункт контекстного меню Вид | Главное меню.

См. также:

Работа в режиме просмотра
Сочетания клавиш и управление мышью
Режим обзора


Режим просмотра :: Меню "Изображение"

В этом меню расположены команды перехода между изображениями, редактирования свойств текущего отображаемого изображения, а также выхода из режима просмотра.
Команда | Описание
Первое изображение | Переходит к самому первому изображению из списка просматриваемых.
Предыдущее изображение | Переходит к предыдущему изображению.
Следующее изображение | Переходит к следующему изображению.
Последнее изображение | Переходит к самому последнему изображению из списка просматриваемых.
Изменить... | Открывает окно свойств текущего изображения, в котором вы можете изменить его данные.
Закрыть | Завершает сеанс просмотра и возвращает программу в режим обзора.


Режим просмотра :: Меню "Вид"

Это меню контролирует вид окна программы.
Команда | Описание
Главное меню | Управляет отображением Главного меню окна просмотра.
Основная панель инструментов | Управляет отображением основной панели инструментов.
Панель инструментов «Преобразования» | Управляет отображением панели инструментов «Преобразования».
Панель инструментов «Показ слайдов» | Управляет отображением панели инструментов «Показ слайдов».
Полноэкранный режим | Осуществляет переключение между полноэкранным и оконным режимами просмотра. Также вы можете осуществить это переключение нажатием клавиши F или средней кнопки (колёсика) мыши.
Обновить | Перегружает текущее отображаемое изображение из файла. Может оказаться полезным, чтобы обновить изображение, изменённое вне программы.
Отображать информацию | Отображает или скрывает строку информации об изображении.
Изменить положение информации | Входит в режим позиционирования строки информации, когда на границах строки отображаются маркеры изменения размера, а саму строку можно передвинуть мышью на другое место. Чтобы завершить позиционирование, выберите этот пункт повторно или щёлкните мышью вне строки.


Режим просмотра :: Меню "Масштаб"

Здесь собраны команды управления масштабом отображения.
Команда | Описание
Увеличить | Увеличивает изображение на величину, указанную в настройках режима просмотра. Аналоги команды — Numpad + или Ctrl+Колёсико вверх.
Уменьшить | Уменьшает изображение на величину, указанную в настройках режима просмотра. Аналоги команды — Numpad - или Ctrl+Колёсико вниз.
Масштаб 1:1 | Устанавливает масштаб отображения 100%, когда одному пикселу изображения соответствует один пиксел на экране. Аналог команды — Numpad /.
Масштаб по размеру окна | Устанавливает такой масштаб отображения, чтобы изображение полностью вписалось в окно. Аналог команды — Numpad *.

NB:
  • Максимальное увеличение изображения составляет 8:1.
  • Максимальное уменьшение изображения составляет 1:10.


Режим просмотра :: Меню "Сервис"

В этом меню расположены команды вызова сервисных функций.
Команда | Описание
Показ слайдов | Показ слайдов | Запускает или останавливает показ слайдов — режим, когда программа сменяет изображения автоматически через заданные промежутки времени и в заданном направлении (см. ниже).
Показ слайдов | Назад | Задаёт режим показа слайдов в направлении от первого изображения к последнему. В отличие от заданной в настройках, эта опция влияет только на текущий сеанс просмотра.
Показ слайдов | Вразброс | Задаёт режим показа слайдов вразброс (случайно). В отличие от заданной в настройках, эта опция влияет только на текущий сеанс просмотра.
Показ слайдов | Вперёд | Задаёт режим показа слайдов в направлении от последнего изображения к первому. В отличие от заданной в настройках, эта опция влияет только на текущий сеанс просмотра.
Показ слайдов | Циклический показ слайдов | Если этот режим включен, показ слайдов зацикливается до бесконечности. В противном случае он завершается по достижении последнего или первого (зависит от направления показа) изображения. В случае показа слайдов вразброс показ слайдов никогда не прекращается автоматически. В отличие от заданной в настройках, эта опция влияет только на текущий сеанс просмотра.
Показ слайдов | Задержка показа | Задаёт задержку в секундах, в течение которой отображается каждое изображение. В отличие от заданной в настройках, эта опция влияет только на текущий сеанс просмотра.
Преобразования | Без поворота | Отменяет поворот текущего отображаемого изображения. Не влияет на следующее отображение этого изображения. Чтобы применить этот режим к изображению постоянно, см. команду Записать преобразования.
Преобразования | Повернуть по часовой стрелке на 90° | Поворачивает текущее отображаемое изображение на 90° по часовой стрелке. Не влияет на следующее отображение этого изображения. Чтобы применить этот режим к изображению постоянно, см. команду Записать преобразования.
Преобразования | Повернуть на 180° | Поворачивает текущее отображаемое изображение на 180°. Не влияет на следующее отображение этого изображения. Чтобы применить этот режим к изображению постоянно, см. команду Записать преобразования.
Преобразования | Повернуть против часовой стрелки на 90° | Поворачивает текущее отображаемое изображение на 90° против часовой стрелки (или на 270° по часовой). Не влияет на следующее отображение этого изображения. Чтобы применить этот режим к изображению постоянно, см. команду Записать преобразования.
Преобразования | Отразить горизонтально | Отражает текущее отображаемое изображение по горизонтали (вдоль вертикальной оси). Не влияет на следующее отображение этого изображения. Чтобы применить этот режим к изображению постоянно, см. команду Записать преобразования.
Преобразования | Отразить вертикально | Отражает текущее отображаемое изображение по вертикали (вдоль горизонтальной оси). Не влияет на следующее отображение этого изображения. Чтобы применить этот режим к изображению постоянно, см. команду Записать преобразования.
Преобразования | Записать преобразования | Сохраняет преобразования, заданные предыдущими командами этого же подменю, в отображаемое изображение. Впоследствии это изображение будет всегда отображаться с применением этих же преобразований.
Настройки программы | Вызывает окно настроек программы, страницу настроек режима просмотра.
Далее следуют пункты инструментов (если они определены).


Режим просмотра :: Меню "Справка"

Это меню служит для доступа к Справочной системе PhoA.
Команда | Описание
Справка | Открывает раздел Справки, посвящённый режиму просмотра.


Работа в режиме просмотра

Поведение программы в режиме просмотра полностью определяется настройками просмотра. Некоторые из параметров настройки можно переопределять в текущем сеансе просмотра. Так, можно переключаться из оконного режима в полноэкранный нажатием клавиши F или средней клавиши мыши. В оконном режиме настройки определяют, увеличивать ли изображение до размеров окна, если оно меньше их, и наоборот, сжимать ли изображение, если оно не вписывается в окно; остаётся ли окно просмотра всегда поверх других окон; для обоих режимов также задаётся цвет незакрытой изображением части окна.

Кроме этого, PhoA может выводить при просмотре информацию о текущем изображении (а иначе зачем она нужна?)

Вы можете увеличивать и уменьшать просматриваемое изображение с помощью колёсика мыши (удерживая Ctrl) или клавишами +, -, *, / цифровой клавиатуры. Если изображение не вписывается в окно просмотра, его можно передвигать, перетаскивая мышью или клавишами со стрелками (также в сочетании с клавишами Ctrl и Shift). Более подробная информация об использовании клавиатуры и мыши в режиме просмотра содержится здесь.


Окно свойств фотоальбома

Это диалоговое окно позволяет задать параметры эскизов, которые будут использоваться в фотоальбоме — размер (ширина и высота в пикселах) и качество. Размеры эскизов по умолчанию — 150х150 пиксел, качество — 40% от полного. Увеличение размеров и качества эскизов приводит к увеличению файла фотоальбома (*.phoa), и наоборот. При слишком низком качестве эскиз будет трудно узнаваем (происходит искажение цветов).

Также здесь можно ввести текстовое описание фотоальбома, которое будет сохранено в файле.

NB:
  • После изменения параметров эскизов эскизы необходимо перестроить, так как изменившиеся параметры будут влиять только на вновь добавляемые изображения. Перестройка эскизов выполняется с помощью Мастера файловых операций.
  • Помимо размеров и степени сжатия, на качество эскизов влияет установленный в настройках программы метод ресэмплинга эскизов (эта настройка едина для всех фотоальбомов, и её изменение также требует перестройки уже имеющихся эскизов).
  • Длина описания не ограничена, но не рекомендуется делать описания свыше 80 печатных страниц — будет неудобно их читать.

Эта операция поддерживает откат

См. также:

Перестройка эскизов изображений
Режим обзора
Настройки программы :: Режим обзора


Окно свойств группы

Это диалоговое окно позволяет просмотреть или изменить свойства группы изображений.

Чтобы отобразить его, выберите команду меню Правка | Изменить..., когда активно дерево групп и в нём выделена одна из групп (но не фотоальбом, представление или результаты поиска).

Элементы интерфейса

ID | Поле только для чтения. Отображает уникальный числовой идентификатор группы, используемый в программе для внутренних целей, наподобие идентификатора у изображения. Идентификатор назначается группе автоматически при её создании, а также при загрузке групп из файла фотоальбома более старых версий программы (до 1.1.5).
Текст | Задаёт текст (наименование) группы, отображаемое в дереве групп.
Описание | Здесь можно ввести дополнительную информацию о том, какие изображения содержит группа. Описание может отображаться во всплывающих подсказках, если это задано в настройках программы.
NB: Переименовать группу можно не только с помощью данного окна, но и непосредственно в дереве. Перейти в режим редактирования имени группы можно нажатием клавиши F2 или левой клавиши мыши на выделенном наименовании группы в режиме обзора.

Эта операция поддерживает откат

См. также:

Режим обзора
Настройки программы :: Общие


Мастер добавления изображений

Этот мастер служит для добавления изображений в текущую группу (в том числе в корневую, т. е. в сам фотоальбом). Если текущая группа не выбрана, эта функция недоступна.

Страницы Мастера:

  • Выбор файлов для добавления
  • Отметка файлов среди выбранных
  • Процесс добавления
  • Протокол добавления

Эта операция поддерживает откат

См. также:

Режим обзора
Работа в режиме обзора


Мастер добавления изображения :: Выбор файлов

Добавление изображений начинается с выбора файлов изображений и/или папок, содержащих файлы изображений.

Элементы интерфейса

Список файлов и папок | Вы должны выделить необходимые элементы в дереве файлов клавиатурой или мышью с помощью клавиш Shift и Ctrl.
Загружать папки вместе с подпапками | Если в дереве выделены папки, то при включенном переключателе выбираются файлы не только из них, но и файлы из всех вложенных папок.
Дополнительно | Отображает/скрывает панель Фильтра выбора файлов, позволяющего наложить дополнительные условия на выбираемые файлы (см. далее).
Наличие файлов в фотоальбоме Позволяет отсеять файлы по их присутствию в фотоальбоме:
  • Не учитывать — фильтр отключен.
  • Только файлы, отсутствующие в фотоальбоме — будут добавлены только те файлы, которые не фигурируют в общем списке изображений альбома.
  • Только файлы, присутствующие в фотоальбоме — в группу добавятся только те файлы, которые уже есть в фотоальбоме.
Маски файлов | Фильтр, ограничивающий добавляемые файлы по их имени и/или расширению. Маска строится по стандартным правилам PhoA.
Время записи файла | Здесь можно указать границы даты и/или времени модификации файла. Таким образом, например, можно выбрать файлы, сохранённые ранее или позже заданной даты. Незаполненное поле означает неактивность фильтра.

Далее >>

См. также:

Мастер добавления изображений
Режим обзора
Работа в режиме обзора


Мастер добавления изображений :: Отметка файлов

На этой странице Вы можете выбрать конкретные файлы из числа выбранных на предыдущей странице, проставив у них символ отметки. По умолчанию отмеченными являются все файлы.

Отметка переключается мышью или клавишей Пробел (в последнем случае инвертируется состояние отметки у всех выделенных файлов). Контекстное меню (вызываемое правой клавишей мыши) предоставляет дополнительные опции.

NB: Эта страница отображается при установках по умолчанию. Вы можете отключить показ данной страницы в настройках диалогов, в этом случае страница будет пропускаться, и после выбора каталогов программа будет непосредственно начинать процесс добавления изображений.

Далее >>

См. также:

Мастер добавления изображений
Режим обзора
Работа в режиме обзора


Мастер добавления изображений :: Добавление изображений

Эта страница отображается в процессе добавления файлов изображений. Программа показывает прогресс добавления изображений и количество произошедших при добавлении сбоев. Впоследствии эти сбои (а также отчёт о добавленных успешно изображениях) можно посмотреть на странице протокола.

Кроме того, программа отображает и созданный эскиз только что добавленного изображения.

NB:
  • Добавление изображений производится в параллельном потоке; прервать процесс добавления можно только в промежутке между обработкой изображений, это слегка замедляет реакцию на нажатие кнопки Прервать.
  • Кроме того, Вы не можете закрыть окно Мастера добавления изображений, пока активен процесс добавления изображений. Для этого необходимо сначала остановить добавление нажатием кнопки Прервать.
  • Процесс добавления изображения включает автозаполнение свойств изображения. Настраивается автозаполнение в настройках диалогов; его результаты можно посмотреть в протоколе добавления изображений.

Далее >>

См. также:

Мастер добавления изображений
Режим обзора
Работа в режиме обзора


Мастер добавления изображений :: Протокол добавления

Здесь отображаются последовательно все операции, произведённые с файлами изображений. Каждый файл из числа выбранных для добавления либо помечается как успешно добавленный, либо его запись содержит текст произошедшей ошибки. Кроме того, в первом случае присутствует информация о результатах автозаполнения свойств изображения.

Элементы интерфейса

Отображать только ошибки | Если этот переключатель включен, список протокола отображает только сбойные файлы, в противном случае показываются также успешно добавленные изображения. Включить фильтрацию полезно в случае, если добавлялось множество файлов, из которых только немногие дали сбои (надеюсь, так в большинстве случаев и будет).
Сохранить в файл... Позволяет записать протокол в простой текстовый файл, полезный, например, для последующего просмотра или машинной обработки.
NB:
  • При сохранении протокола сохраняются всегда все имеющиеся записи независимо от состояния переключателя Отображать только ошибки.
  • Сбойные записи в протоколе всегда имеют в начале строки последовательность символов [!], в то время как успешно добавленные начинаются с символов [+]. Это позволяет легко искать, скажем, ошибки в протоколе (если только у вас нет обыкновения включать в имена файлов эти последовательности символов).
Контекстное меню (доступное по нажатию правой кнопки мыши в списке) предоставляет дополнительные опции:
Копировать | Копирует текущую выбранную строкув буфер обмена.
Найти... | Отображает стандартный диалог поиска текста, позволяющий произвести поиск в списке протокола, например, какого-либо имени файла.

Вы можете просмотреть протокол до завершения добавления всех файлов, прервав процесс добавления и нажав кнопку Далее. После этого можно (нажав Назад) вернуться к странице добавления и продолжить процесс.

Эта операция поддерживает откат

См. также:

Мастер добавления изображений
Режим обзора
Работа в режиме обзора


Окно свойств изображений

Это окно служит для просмотра и редактирования свойств выделенных изображений. Чтобы отобразить его, выделите одно или несколько изображений в окне эскизов и выберите команду меню Правка | Изменить... или нажмите комбинацию клавиш Alt+Enter, когда окно эскизов имеет фокус ввода.

В окне представлены несколько страниц, переключаемых с помощью панели кнопок в левой части диалога, или нажатием комбинаций клавиш Ctrl+Цифра:
Страница | Комбинация клавиш | Назначение
Свойства файла | Ctrl+1 | Просмотр общих сведений о файлах изображений
Метаданные | Ctrl+2 | Просмотр метаданных, содержащихся в файлах изображений
Просмотр | Ctrl+3 | Просмотр самих изображений в выбранном масштабе
Данные | Ctrl+4 | Просмотр или редактирование данных изображений
Ключевые слова | Ctrl+5 | Просмотр или редактирование ключевых слов изображений
Группы | Ctrl+6 | Определение или изменение принадлежности изображений к группам

Эта операция поддерживает откат

См. также:

Режим обзора
Работа в режиме обзора


Окно свойств изображения :: Свойства файла

Здесь отображается список файлов выделенных изображений. Раскрыв имя файла, вы можете просмотреть его свойства (тип, размеры, время создания, записи и доступа и т.д.).

Нажатием правой кнопки мыши здесь Вы можете вызвать стандартное контекстное меню Проводника для файла.

Элементы интерфейса

Изменить файл... Отображает стандартный диалог выбора файла изображения, на который нужно исправить текущий выбранный в списке файл.
NB: Вы можете указать в настройках диалогов сразу разворачивать свойства для всего списка файлов.

См. также:

Режим обзора
Работа в режиме обзора


Окно свойств изображения :: Метаданные

Эта страница отображает метаданные, содержащиеся в файлах изображений. Метаданные выводятся для каждого файла изображения, вы можете просмотреть их, раскрыв имя файла.

Если файл не содержит метаданных, напротив его имени выводится соответствующая информация.

Нижняя панель, Описание, отображает дополнительную информацию о выбранном метатеге. Эта панель видима по умолчанию, но может быть скрыта, если нажать кнопку X на ней. Чтобы вновь отобразить эту панель, выберите соответствующий пункт из контекстного меню.

NB:
  • Вы можете указать в настройках диалогов сразу разворачивать метаданные для всего списка файлов.
  • Метаданные могут быть использованы для автозаполнения свойств изображений при добавлении их в фотоальбом. Указывается это также в настройках диалогов.
  • Названия метатегов не локализованы и приводятся на английском языке. Связано это с тем, что их шибко много :) и, кроме того, они постоянно добавляются. Кому нужно, тот разберётся.
  • Описания метатегов также не локализованы.

См. также:

Метаданные
Режим обзора
Работа в режиме обзора
Автозаполнение свойств изображений


Окно свойств изображения :: Просмотр и настройка

Здесь вы можете просмотреть любое из выделенных изображений в выбранном масштабе, а также настроить преобразования, применяемые к изображению при просмотре. Файл изображения (если изображений несколько) выбирается из выпадающего списка в верхней части страницы.

Элементы интерфейса

Увеличить | Увеличивает изображение на величину, указанную в настройках просмотра.
Уменьшить | Уменьшает изображение на величину, указанную в настройках просмотра.
Масштаб 1:1 | Отображает изображение в масштабе 1:1 (когда каждый пиксел изображения соответствует одному пикселу на экране).
В размер окна | Масштабирует изображение так, чтобы оно точно вписалось в окно. Это режим по умолчанию.
Без поворота | Не применять поворота к изображению при его отображении.
Повернуть по часовой стрелке на 90° | Применить поворот по часовой стрелке на 90° к изображению при его отображении.
Повернуть на 180° | Применить поворот на 180° к изображению при его отображении.
Повернуть против часовой стрелки на 90° | Применить поворот против часовой стрелки на 90° (или по часовой стрелке на 270°) к изображению при его отображении.
Отразить горизонтально | Применить горизонтальное отражение к изображению при его отображении.
Отразить вертикально | Применить вертикальное отражение к изображению при его отображении.
NB:
  • Эти команды доступны также из контекстного меню, вызываемого нажатием правой кнопки мыши.
  • Ctrl+Щелчок правой кнопкой вызывает системное контекстное меню (меню Проводника) для текущего отображаемого файла.
  • Команды преобразований применяются ко всем выделенным изображениям. При этом, если какое-либо свойство преобразования (например, поворот) не совпадает у выделенных изображений, то все кнопки этого преобразования (поворота в нашем случае) будут отжаты. Если теперь применить поворот, значение поворота будет совпадать у всех выделенных изображений.

Панорамирование изображения (если оно не вписывается в окно) осуществляется перетаскиванием его мышью. Кроме того, колёсико мыши также может использоваться для масштабирования изображения.

NB: Для ускорения отображения в качестве фильтра ресэмплинга здесь всегда используется Nearest neighbor.

См. также:

Режим обзора
Работа в режиме обзора


Окно свойств изображения :: Данные

Данные изображений

Эта страница диалога свойств позволяет поменять основную часть изменяемых данных изображений:

  • Дату — дата изображения. Формат даты определяется региональными настройками Windows. Если данных о дате изображения нет, это поле не заполнено.
  • Время — время изображения. Если данных о времени нет, оставьте поле пустым.
  • Место — место изображённых событий. Выпадающий список отображает все имеющиеся в фотоальбоме варианты.
  • Номер/название плёнки — номер, присвоенный плёнке при проявке, или данное ей Вами название. Выпадающий список отображает все имеющиеся в фотоальбоме варианты.
  • Номер кадра — без комментариев.
  • Автор — имя автора или фотографа. Выпадающий список отображает все имеющиеся в фотоальбоме варианты.
  • Описание — краткое описание изображения, используемое для отображения при просмотре.
  • Примечание — все данные, не попавшие в остальные поля.
  • Наименование/код носителя — название носителя, на котором расположен файл изображения (например, номер компакт-диска). Выпадающий список отображает все имеющиеся в фотоальбоме варианты.

Более подробная информация о данных изображения находится здесь.

Несколько изображений

PhoA поддерживает редактирование данных для любого числа изображений одновременно. Если говорить о текущей странице, то здесь используется незамысловатая схема обозначения свойств:

  • Если какое-то свойство совпадает у всех выделенных изображений, соответствующее поле ввода будет белого цвета (точнее, цвета окна в Windows).
  • Если значения определённого свойства различаются у разных изображений, соответствующее поле закрашивается в серый цвет (а точнее, в цвет рельефных объектов Windows). Если Вы начнёте изменять данные в этом поле, то у всех выделенных изображений соответствующее свойство примет введённое Вами значение, и поле ввода перекрасится в белый цвет. В противном случае эти данные останутся неизменными (и, соответственно, различными).

Впоследствии по введённым Вами данным можно осуществлять поиск и выборку изображений, поэтому стоит ответственно отнестись к тому, чего вы там вводите.

Эта операция поддерживает откат

См. также:

Данные изображений
Автозаполнение свойств изображений
Режим обзора
Работа в режиме обзора


Окно свойств изображения :: Ключевые слова

Каждое изображение имеет среди прочих своих данных список ключевых слов, описывающих его содержимое. Чаще всего это список людей, предметов или событий, изображённых на фотографии, но это могут быть и любые другие слова, которые приходят Вам на ум, когда Вы созерцаете сие изображение (соответственно, определяется словарным запасом :)

Преимущество ключевых слов перед простым текстом состоит в том, что их не обязательно набирать вслепую — их можно выбрать из списка. Кроме того, по ним можно построить представление и наблюдать, как, например, меняется их тематика от года к году (весьма интересное наблюдение, кстати). И ещё: по списку ключевых слов сразу видно, в скольких изображениях оно участвует.

Список ключевых слов

Этот список представляет собой перечень всех ключевых слов, встречающихся в изображениях текущего фотоальбома. Серым цветом в скобках после слова выводится общее количество вхождений слова в изображения (поскольку каждое слово может быть использовано в изображении только единожды, то это число представляет собой количество изображений, это слово содержащих).

Если ключевое слово содержится в каких-то из выделенных изображений, то у слова будет проставлен знак отметки (галка, если слово есть во всех выделенных изображениях и серая галка или квадратик, в зависимости от стиля переключателей, если есть, но не во всех), а в скобках после слова будет написано два числа через слэш: первое показывает, в скольких изображениях из числа выделенных это ключевое слово используется, а второе — как обычно, общее число вхождений слова в изображениях фотоальбома.

Соответственно, если ключевое слово в выделенных изображениях не присутствует, отметки у него нет.

Поскольку сравнение ключевых слов всегда регистронезависимо, программа не различает слова баня и БаНя.

На данной странице Вы можете добавлять ключевые слова. Чтобы отличить вновь добавленные слова от уже имеющихся, они выглядят по-разному:

  • Встречающиеся в фотоальбоме ключевые слова имеют значок ключика и пишутся шрифтом чёрного цвета.
  • Вновь добавленные слова имеют значок звёздочки (или как эту краказяблу назвать) и пишутся синим.

Операции с ключевыми словами

С помощью этой страницы вы можете свободно модифицировать список ключевых слов выделенных изображений. Для этого используются кнопки панели инструментов, расположенной в верхней части страницы.

NB: Эти же операции доступны через контекстное меню, вызываемое нажатием правой кнопки мыши на списке.

Элементы интерфейса

Только отмеченные | Если включено (кнопка нажата), в списке отображаются только те слова, которые имеют символ отметки, иначе отображаются все слова. Этот переключатель влияет только на отображение ключевых слов, и никак не влияет на сам их список.
Добавить | Добавляет новое ключевое слово в список, проставляет у него отметку и переходит в режим редактирования его. Если отметка не будет убрана, при нажатии ОК ключевое слово добавится во все выделенные изображения.
Изменить Входит в режим редактирования ключевого слова. Нюансы:
  • Ключевое слово изменится только в тех изображениях, в которых оно было.
  • Если ключевого слова не было в выделенных изображениях (не было отметки у ключевого слова), то оно не изменится нигде.
  • Если состояние отметки изменяется в сторону включения (например, с неполной на полную), то новое слово добавится в изображения, где не было старого слова.
  • Если отметка выключается, то старое слово просто будет удалено из изображений (естественно, из числа выделенных), в которых оно было.
NB: В режим редактирования слова можно также войти, повторно нажав мышью на выделенном слове.
Отметить все | Проставляет отметку всем ключевым словам в списке (т. е. после этого все выделенные изображения будут иметь все вхождения ключевых слов).
Снять со всех | Удаляет отметку у всех ключевых слов в списке (выделенные изображения не будут иметь ключевых слов вообще).
Инвертировать | Переключает состояние отметки ключевых слов на противоположное.
NB: Почему нет кнопки Удалить? Специально, чтобы не вносить двусмысленности. Если вы хотите удалить ключевое слово из изображений, снимите с него отметку.

Эта операция поддерживает откат

См. также:

Данные изображений
Режим обзора
Работа в режиме обзора


Окно свойств изображения :: Группы

На этой странице Вы можете наглядно увидеть, в каких группах присутствуют изображения. Кроме того, здесь можно оперативно добавить изображения во множество групп, или удалить их из нескольких групп.

Аналогично ключевым словам, изменения здесь вносятся простановкой отметки у элементов списка, и аналогично им же напротив элементов выводятся числа в скобках: если число одно — оно показывает количество изображений в группе; если два (через слэш), то первое означает количество изображений в данной группе из числа выделенных, а второе — уже общее количество изображений в ней.

Аналогично ведёт себя здесь и отметка — если ни одно из выделенных изображений не содержится в конкретной группе, то отметки у неё нет. Если часть выделенных изображений содержится, а часть нет — отметка будет неполной. И если все выделенные изображения входят в эту группу, отметка будет полной.

Далее Вы можете развивать этот сюжет по своему усмотрению.

NB: Вы не можете проставить отметки так, чтобы какие-то изображения совсем перестали числиться в группах — для этого нужно было бы их (изображения) просто удалить, а удаление изображений — этот совсем другая операция. Поэтому PhoA не даст Вам внести такие изменения, предупредив соответствующим сообщением.

Эта операция поддерживает откат

См. также:

Режим обзора
Работа в режиме обзора


Окно сортировки изображений

Данная функция позволяет изменить порядок следования изображений в текущей группе или во всех группах фотоальбома на основе их данных.

Если текущая группа не выбрана, то сортировка может быть произведена только по всем группам фотоальбома.

Кроме того, если в момент вызова диалога в дереве групп выделен узел результатов поиска, то выбор сортировки В текущей группе произведёт сортировку результатов поиска, в противном случае порядок следования изображений в группе результатов поиска никак не затрагивается.

Элементы интерфейса

Порядок сортировки изображений Порядок сортировки определяется критериями, которых можно указывать произвольное количество.

Каждый критерий в списке представляет из себя свойство изображения и направление сортировки (по возрастанию / по убыванию). Добавляются критерии автоматически, когда вы из выпадающего списка выбираете свойство, по которому нужно сортировать.

Чтобы отобразить список, нажмите мышью кнопку в первом столбце или клавишу Пробел, когда подсвечен первый столбец.

Чтобы переключить направление сортировки, нажмите мышью индикатор направления или клавишу Пробел, когда подсвечен второй столбец.

Вы также можете менять порядок элементов в списке, перетаскивая их мышью или с помощью комбинаций клавиш Ctrl+Вверх и Ctrl+Вниз.

Эта операция поддерживает откат

См. также:

Режим обзора
Работа в режиме обзора


Окно операций с изображениями

Функция позволяет произвести несколько операций между выделенными изображениями и одной из групп (кроме текущей) фотоальбома. Эти операции включают:

  • Перемещение выделенных изображений в выбранную группу (аналог простого перетаскивания выделенных изображений мышью в эту группу);
  • Добавление (копирование) выделенных изображений к выбранной группе (аналог перетаскивания выделенных изображений мышью в эту группу с нажатой клавишей Ctrl);
  • Удаление выделенных изображений из выбранной группы (группа будет содержать все прежние изображения, кроме копий выделенных изображений);
  • Пересечение выделенных изображений с изображениями выбранной группы (группа будет содержать только те изображения, которые идентичны выделенным).

Это позволяет выполнять различные задачи при упорядочивании содержимого фотоальбома (например, можно убрать повторяющиеся изображения из другой группы или скопировать часть изображений из одной группы в другую).

Эта операция поддерживает откат

См. также:

Сочетания клавиш и управление мышью
Работа в режиме обзора


Статистика фотоальбома

Функция подсчёта статистики фотоальбома формирует сводные данные по изображениям и группам и отображает их.

Основные пункты статистики фотоальбома:
Название | Описание
Файл фотоальбома | Свойства файла фотоальбома, представляются аналогично свойствам файлов изображений. Кроме того, присутствует пункт Версия файла фотоальбома, отображающий версию загруженного файла.
Количество различных изображений | Количество различных изображений в фотоальбоме.
Количество вложенных групп | Количество групп, входящих в фотоальбом.
Количество изображений в группе | Количество изображений непосредственно в фотоальбоме (корневом элементе дерева групп).
Общее количество изображений | Общее количество ссылок на изображения (необязательно различные) в группе-фотоальбоме и всех вложенных группах.
Общее количество различных изображений | Общее количество ссылок на различные изображения в группе-фотоальбоме и всех вложенных группах.
Суммарный размер файлов изображений | Сумма размеров файлов изображений, входящих в группу-фотоальбом и во вложенные группы.
Средний размер файла изображения | Средний размер файла изображения из числа изображений, входящих в группу-фотоальбом и во вложенные группы.
Суммарный размер эскизов | Сумма размеров данных эскизов изображений, входящих в группу-фотоальбом и во вложенные группы.
Средний размер эскиза | Средний размер данных эскиза изображения из числа изображений, входящих в группу-фотоальбом и во вложенные группы.
Самый большой файл изображения | Имя файла изображения, имеющего самый большой размер, из числа изображений, входящих в группу-фотоальбом и во вложенные группы.
Размер самого большого файла | Размер файла изображения из предыдущего пункта.
Самый маленький файл изображения | Имя файла изображения, имеющего самый маленький размер, из числа изображений, входящих в группу-фотоальбом и во вложенные группы.
Размер самого маленького файла | Размер файла изображения из предыдущего пункта.

Если в дереве групп выделена какая-то группа, то далее дополнительно приводятся вышеперечисленные данные (кроме имени файла и числа изображений в фотоальбоме) и относительно этой группы.

См. также:

Режим обзора
Работа в режиме обзора


Окно поиска изображений

PhoA обладает достаточно мощным средством выборки изображений. Для отображения окна поиска необходимо выбрать пункт меню Сервис | Поиск... или нажать клавишу F3 в режиме обзора.

Элементы интерфейса

Искать Определяет область поиска изображений:
  • В фотоальбоме — поиск осуществляется среди всех имеющихся изображений.
  • В текущей группе — производить поиск только среди изображений текущей выбранной группы (недоступно, если нет выбранной группы).
  • В результатах поиска — искать среди результатов предыдущего поиска (доступно, только если имеется папка Результаты поиска).
Критерии поиска PhoA поддерживает два варианта поиска:
  • Простой поиск позволяет задать набор свойств изображений и наложить условия на их значения.
  • Поиск по выражению даёт возможность написания произвольного выражения фильтра, определяющего критерии поиска.
Найти Запускает поиск изображений. Выбранные в результате поиска изображения (если они есть) попадают в папку Результаты поиска, которая отображается в корневом каталоге дерева групп. Для папки результатов поиска доступны те же операции, что и для всех групп изображений, за исключением добавления и удаления из неё изображений.

См. также:

Типы данных изображений
Данные изображений
Работа в режиме обзора
Сочетания клавиш и управление мышью


Поиск изображений :: Простой поиск

Простой поиск позволяет наглядно задать условия выборки изображений на основе значений их свойств.

Элементы интерфейса

Сброс | Стирает все введённые критерии.
Удалить | Удаляет текущий выделенный критерий.
Преобразовать в выражение | Составляет выражение для поиска по выражению на основе уже введённых критериев и помещает его в редактор выражения.
Список критериев поиска Вы вводите условия поиска в таблице критериев, которые определяются следующими данными:
  • Свойство изображения — один из поисковых элементов данных изображения, для которого вводится критерий.
  • Условие — одно из условий сравнения свойства, набор возможных условий определяется типом данных.
  • Значение — значение, с которым сравнивается свойство изображения.

Для того, чтобы добавить новый критерий, просто выберите необходимое свойство изображения, нажав кнопку меню в последней, незаполненной строке таблицы.

Чтобы передвигаться по ячейкам таблицы, используются клавиши со стрелками. Для раскрытия выпадающего списка существует комбинация клавиш Alt+Вниз.

Значения условий хранят историю вводимых вами значений.

Программа выбирает те изображения, которые соответствуют всем критериям поиска одновременно (то есть здесь действует условие И).

См. также:

Поиск изображений
Поиск изображений :: Поиск по выражению
Данные изображений


Поиск изображений :: Поиск по выражению

Поиск по выражению является наиболее мощным средством поиска изображений в PhoA.

Подробное описание языка поисковых выражений (или выражений фильтра изображений) приведено здесь.

Подробное описание стандартного редактора выражений фильтра PhoA см. здесь

См. также:

Поиск изображений
Поиск изображений :: Простой поиск
Выражения фильтра изображений


Поиск изображений :: Типы данных изображений

Согласно таблице данных изображения, PhoA использует следующие типы данных в свойствах изображений:
Тип данных | Описание и критерии
Целое или натуральное число | Данные представляют собой обычное целое число, которое можно проверить на равенство, неравенство и т. д.
Строка | Любые символьные данные. Поиск по строке или подстроке в любых вариантах. Поиск регистронезависим.
Пиксельный формат | Не является поисковым типом.
Дата | Данные проверяются по критериям, аналогичным тем, что используются у чисел.
Время | Данные проверяются по критериям, аналогичным тем, что используются у чисел.
Размеры (Ширина х Высота) | Не является поисковым типом.
Список строк | Это список ключевых слов. Слова можно вводить вручную или нажать кнопку "..." в поле ввода для выбора ключевых слов из списка. Критерии включают условия присутствия и отсутствия заданных (или всех) слов.
Поворот изображения | Не является поисковым типом.
Отражения изображения | Не является поисковым типом.

См. также:

Поиск
Данные изображений
Мастер добавления изображения
Окно изменения изображения


Окно выбора ключевых слов

Окно появляется при вызове списка ключевых слов из окна поиска. Программа составляет список всех ключевых слов, использованных в изображениях, и выводит их в алфавитном порядке. Числа в скобках после ключевых слов обозначают количество вхождений слов в изображения фотоальбома.

Вы можете отметить те ключевые слова, по которым нужно провести поиск.

Элементы интерфейса

Сброс Снимает отметку со всех пунктов.
NB: Если ключевое слово содержит символы пробела или запятой, при подстановке оно автоматически берётся в двойные кавычки, поскольку эти символы являются разделителями списка слов.

См. также:

Поиск изображений
Ключевые слова изображений
Данные изображений


Окно свойств представления

Это окно служит для добавления или изменения свойств представления.

Наименование служит для того, чтобы можно было понять назначение представления; списки группировок и сортировок определяют алгоритм построения представления; выражение фильтра позволяет задать выражение условия отбора изображений для представления.

Более подробно о представлениях рассказано здесь.

См. также:

Работа в режиме обзора


Окно выбора группы фотоальбома (для помещения представления)

Это окно служит для указания, в какую из групп фотоальбома необходимо поместить иерархию папок, сформированную представлением:

Вся структура папок и изображений представления будет скопирована в указанную группу фотоальбома (в качестве неё можно указать и сам фотоальбом). Далее Вы можете производить необходимые операции с полученными группами и изображениями, как обычно.

См. также:

Работа с представлениями
Работа в режиме обзора


Окно свойств инструмента

Это окно служит для просмотра и редактирования свойств инструмента. Чтобы отобразить его, выберите команду Изменить... на странице Инструменты диалога настроек программы.

Элементы интерфейса

Маски файлов | Определяют набор файлов, к которым применим инструмент.
Вид | Задаёт вид инструмента.
Наименование | Определяет текст пункта меню, создаваемого для инструмента. Вы можете создать горячую клавишу для вызова инструмента, введя символ & перед одной из букв. Чтобы набрать символ & в тексте пункта, необходимо его продублировать.
Подсказка | Подсказка отображается в строке состояния. В случае, если в строке имеется символ | (вертикальная черта), то в строке состояния отображается текст после него; текст до этого символа отображается в виде всплывающей подсказки кнопки на панели инструментов.
Команда (приложение) | Имеет смысл только для пользовательского действия. Задаёт исполняемый файл, которому будут переданы файлы в качестве параметров командной строки. Чтобы выбрать файл, можно воспользоваться кнопкой Обзор....
Параметры | Задаёт дополнительные параметры командной строки, передаваемые приложению.
Окно | Определяет состояние главного окна указанного приложения после его запуска.
Папка | Задаёт рабочую папку приложения. Кнопка Обзор... позволяет выбрать папку.
Использование инструмента | Определяет, в каких меню команда инструмента будет появляться.

См. также:

Инструменты
Настройки программы :: Инструменты
Режим обзора
Режим просмотра


Мастер операций с файлами изображений

Этот мастер служит для выполнения различных операций, затрагивающих файлы изображений. Вызывается он из режима обзора выбором команды меню Сервис | Операции с файлами... или с помощью комбинации клавиш Ctrl+R.

Мастер позволяет выполнять следующие задачи:

  • Копирование файлов изображений в заданную папку
  • Перемещение файлов изображений в заданную папку
  • Удаление ненужных изображений вместе с файлами
  • Перестройка эскизов изображений

Описания страниц Мастера:

  1. Выбор задачи
  2. Выбор изображений для операции
  3. Выбор папки назначения
  4. Опции копирования/перемещения (страница 1)
  5. Опции копирования/перемещения (страница 2)
  6. Опции создания CD/DVD
  7. Опции удаления
  8. Процесс выполнения операции
  9. Протокол операции

См. также:

Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Операция копирования файлов изображений

Эта операция позволяет получить копию набора файлов изображений в заданной папке, и поддерживает множество опций. В частности, она позволяет подготовить фотоальбом для записи на сменный носитель, такой как CD, DVD и др.

Чтобы выполнить эту операцию, необходимо запустить Мастер операций с файлами изображений и на странице выбора задачи выбрать Копировать файлы изображений в папку.

Далее последовательность страниц такова:

  • Выбор изображений для операции
  • Выбор папки назначения
  • Опции копирования/перемещения (страница 1)
  • Опции копирования/перемещения (страница 2)
  • Опции создания CD/DVD
  • Процесс выполнения операции
  • Протокол операции

См. также:

Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Операция перемещения файлов изображений

Эта операция в целом идентична операции копирования файлов, за исключением двух моментов:

  • Ссылки на файлы в изображениях фотоальбома в процессе перемещения исправляются на новые.
  • По выбору пользователя эта операция позволяет удалить исходные файлы: совсем или в Корзину.

Операция перемещения полезна, если Вы хотите реорганизовать файлы в Вашем фотоальбоме, например, перенести их в другую папку или на другой диск.

Чтобы выполнить эту операцию, необходимо запустить Мастер операций с файлами изображений и на странице выбора задачи выбрать Переместить файлы изображений в папку.

Далее последовательность страниц такова:

  • Выбор изображений для операции
  • Выбор папки назначения
  • Опции копирования/перемещения (страница 1)
  • Опции копирования/перемещения (страница 2)
  • Опции создания CD/DVD
  • Процесс выполнения операции
  • Протокол операции

См. также:

Операция копирования файлов
Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Операция удаления файлов изображений

Эта операция позволяет удалить ненужные файлы изображений (естественно, вместе с соответствующими изображениями, так как иначе эти изображения ссылались бы на несуществующие файлы). Мастер позволяет удалить файлы изображений совсем или переместить их в Корзину.

Чтобы выполнить эту операцию, необходимо запустить Мастер операций с файлами изображений и на странице выбора задачи выбрать Удалить изображения и файлы.

Далее последовательность страниц такова:

  • Выбор изображений для операции
  • Опции удаления
  • Процесс выполнения операции
  • Протокол операции

См. также:

Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Операция перестройки эскизов

Перестройка эскизов требуется прежде всего тогда, когда меняются параметры эскизов (определяемые в свойствах альбома): размеры, качество или метод ресэмплинга (последний задаётся в настройках режима обзора). В этом случае необходимо построить новые эскизы — в соответствии с новыми параметрами. Также эта операция может оказаться полезной, если изменились исходные изображения альбома.

Чтобы выполнить эту операцию, необходимо запустить Мастер операций с файлами изображений и на странице выбора задачи выбрать Перестроить эскизы.

Далее последовательность страниц такова:

  • Выбор изображений для операции
  • Процесс выполнения операции
  • Протокол операции

См. также:

Мастер операций с файлами изображений
Данные изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Выбор задачи

Эта страница Мастера служит для выбора одной из операций с файлами изображений:

  • Копирование файлов изображений в заданную папку
  • Перемещение файлов изображений в заданную папку
  • Удаление ненужных изображений вместе с файлами
  • Перестройка эскизов изображений

См. также:

Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Выбор изображений

Эта страница Мастера служит для выбора изображений и применима для следующих операций:

  • Копирование файлов изображений в заданную папку
  • Перемещение файлов изображений в заданную папку
  • Удаление ненужных изображений вместе с файлами
  • Перестройка эскизов изображений

Элементы интерфейса

Выбранные изображения | Выбранная Вами операция будет выполняться с изображениями, выбранными в окне просмотра эскизов. В случаях, когда операции требуется группа изображений, используется непосредственно выбранная в дереве группа фотоальбома или представления. Этот режим выбирается автоматически, если вызов Мастера производится в момент, когда окно просмотра эскизов активно, и там имеются выбранные изображения.
Все изображения фотоальбома/представления | Операция будет использовать все изображения и все группы фотоальбома (при просмотре групп изображений) или представления (когда активно представление).
Изображения в выбранных группах | Вы выбираете, к каким группам и изображениям будет применяться операция, путём простановки отметки в приведённом дереве групп. Отметку можно установить только у групп, которые содержат изображения. Этот режим выбирается автоматически, если вызов Мастера производится в момент, когда активно дерево групп; текущая выбранная группа сразу становится отмеченной (если в ней есть изображения).
Дополнительные опции доступны через контекстное меню, вызываемое нажатием правой кнопки мыши или комбинацией клавиш Shift+F10
Отметить все группы | (клавиши Ctrl+A) — проставляет отметку у всех групп, имеющих изображения.
Снять отметку у всех групп | (клавиши Ctrl+D) — удаляет отметку у всех отмеченных групп.
Инвертировать отметку у групп | (клавиши Ctrl+I) — меняет состояние отметки у всех групп на противоположное.

Строка информации в нижней части страницы отображает, сколько именно групп и изображений отобрано для операции; также отображается суммарный размер, занимаемый файлами этих изображений.

NB:
  • Если опции копирования/перемещения позволяют создавать дубликаты файлов, суммарный их объём может оказаться больше указанного.
  • Занимаемое файлом на диске место, как правило, больше его размера — это следует учитывать при подготовке набора файлов для записи на сменный носитель.

См. также:

Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Выбор папки назначения

Эта страница Мастера служит для выбора папки назначения и применима для следующих операций:

  • Копирование файлов изображений в заданную папку
  • Перемещение файлов изображений в заданную папку

Вы должны выбрать папку в дереве или ввести путь к ней в строке ввода.

Элементы интерфейса

Создать папку Эта кнопка создаёт папку внутри текущей выбранной в дереве, выделяет её и входит в режим редактирования её имени.
NB: Для операций копирования и перемещения файлов Вы можете указать имя новой, несуществующей папки — тогда она будет создана автоматически в процессе выполнения операции.

См. также:

Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Опции копирования/перемещения, страница 1

Эта страница Мастера служит для задания параметров следующих операций с файлами:

  • Копирование файлов изображений в заданную папку
  • Перемещение файлов изображений в заданную папку

Элементы интерфейса

Режим размещения файлов
Эти опции определяют способ расположения файлов в выбранной папке назначения.
Расположить все файлы в единственной папке В этом режиме все файлы помещаются в папке, указанной как папка назначения.
NB: Следует принять во внимание, что имена файлов могут совпадать. Это может создать конфликт при размещении всех файлов в единственной папке.
Сохранять исходную структуру папок | В таком варианте программа располагает файлы, копируя структуру папок, в которых они находятся. Пример см. ниже.
Использовать путь относительно папки | PhoA автоматически определяет общую для всех выбранных изображений часть пути и помещает возможные допустимые варианты общего пути в данный список.
Пример размещения файлов с сохранением исходной структуры папок
Допустим, мы выбрали для копирования/перемещения следующие изображения:
  • C:\Мои документы\Фотоальбом\Весна 1812\pic001.jpg
  • C:\Мои документы\Фотоальбом\Лето 1812\pic002.jpg
  • C:\Мои документы\Фотоальбом\Осень 1812\pic003.jpg
  • C:\Мои документы\Фотоальбом\Зима 1812\pic004.jpg
  • C:\Мои документы\Фотоальбом\Зима 1812\Москва\pic005.jpg

Программа автоматически определяет, что самый длинный общий путь у этих изображений — это C:\Мои документы\Фотоальбом, и подставляет в список возможных базовых папок его и остальные допустимые варианты: C:\Мои документы и C:\; последним добавляется вариант (нет): при выборе его буква исходного диска также превратится в папку внутри папки назначения.

Предположим теперь, что мы выбрали в качестве базовой папки C:\Мои документы, а в качестве папки назначения, скажем, D:\CD-ROM\Disk1. После выполнения операции мы получим следующие файлы:

  • D:\CD-ROM\Disk1\Фотоальбом\Весна 1812\pic001.jpg
  • D:\CD-ROM\Disk1\Фотоальбом\Лето 1812\pic002.jpg
  • D:\CD-ROM\Disk1\Фотоальбом\Осень 1812\pic003.jpg
  • D:\CD-ROM\Disk1\Фотоальбом\Зима 1812\pic004.jpg
  • D:\CD-ROM\Disk1\Фотоальбом\Зима 1812\Москва\pic005.jpg

Программа возьмёт D:\CD-ROM\Disk1 в качестве отправной точки, и каждый файл изображения будет иметь в своём пути папку Фотоальбом, поскольку путь берётся относительно папки C:\Мои документы.

Помещать файлы в папки, повторяя структуру групп изображений | В этом режиме PhoA будет раскладывать файлы по папкам, копируя существующую иерархию групп в фотоальбоме или представлении (смотря что в данный момент отображается).
Использовать путь относительно группы | В этом списке Вы можете указать, начиная с какой группы программа копирует структуру папок. По умолчанию подставляется самая дальняя от корневого элемента (фотоальбома или представления) группа, являющаяся родительской для всех выбранных групп изображений (так, если папка фотоальбома тоже входит в число выбранных, или выбрано копирование/перемещение всего фотоальбома, в этом списке будет единственный элемент — Фотоальбом). Также в список заносятся пути ко всем родительским группам этой группы, включая и окончательного родителя всех групп — Фотоальбом или текущее представление.
Разрешать несколько копий файла | Поскольку в PhoA одно изображение может входить в несколько групп, при копировании структуры групп в виде папок может потребоваться положить несколько копий одного файла в разные папки. Если данный переключатель включен, программа так и поступит, в противном случае файл будет скопирован только единожды (в первую папку по направлению обхода).
Заменять недопустимые символы символом | Задаёт символ, на который заменять символы, недопустимые в именах папок (это следующие символы: \ / : * ? " < > |). Например, если этот символ установлен в _ (по умолчанию), а группа называется Друзья/Враги, то для неё будет создана папка Друзья_Враги.

См. также:

Опции копирования/перемещения (страница 2)
Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Опции копирования/перемещения, страница 2

Эта страница Мастера служит для задания параметров следующих операций с файлами:

  • Копирование файлов изображений в заданную папку
  • Перемещение файлов изображений в заданную папку

Элементы интерфейса

Если исходный файл не существует Имеет смысл только для операции перемещения файлов и определяет поведение программы, если в процессе перемещения обнаружено отсутствие исходного файла:
  • Считать ошибкой — протоколирует ошибку и пропускает изображение.
  • Обновить ссылку только если файл назначения существует — если файл, который определён как файл назначения, существует — в изображении будет установлена ссылка на него, иначе изображение будет пропущено. Этот режим полезен в случае, если Вы переместили файлы, не пользуясь средствами программы, и хотите восстановить правильные ссылки — для этого укажите папку, где находятся новые файлы (необходимо учесть также прежнюю и новую структуру каталогов).
  • Обновить ссылку в любом случае — ссылка на файл изображения обновляется всегда, независимо от наличия исходного и целевого файлов.
Удалять исходные файлы | Имеет смысл только для операции перемещения файлов. Если опция включена, после успешного копирования и исправления ссылки файл будет удалён.
Удалять в Корзину Имеет смысл только для операции перемещения файлов.
  • Если эта опция выключена, файл удалится окончательно и бесповоротно.
  • Если опция включена, файл будет перемещён в Корзину (если это возможно на данном компьютере).
Если файл назначения уже существует Задаёт режим перезаписывания существующих файлов:
  • Пропускать текущее изображение — если файл назначения существует, программа посчитает это ошибкой, занесёт её в протокол и оставит прежний файл на месте.
  • Выдать запрос на перезапись файла — при обнаружении существующего файла программа выдаст запрос на перезапись файла. В случае отказа это изображение также будет занесено в протокол как сбойное.
  • Всегда перезаписывать файл — существующий файл будет перезаписан новым без каких-либо предупреждений.
Опции CD/DVD
Настроить также опции записи на CD/DVD | Если включен, то после нажатия кнопки Далее > Мастер отобразит страницу опций CD/DVD, в противном случае программа начнёт процесс обработки (если указано в Настройках, то после выдачи соответствующего предупреждения).

См. также:

Опции копирования/перемещения (страница 1)
Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Опции создания CD/DVD

Эта страница Мастера служит для задания дополнительных параметров создания CD, DVD и прочих сменных носителей при следующих операциях с файлами:

  • Копирование файлов изображений в заданную папку
  • Перемещение файлов изображений в заданную папку

Элементы интерфейса

Создать файл фотоальбома с выбранными изображениями | Если включено, программа создаст новый фотоальбом на основе выбранных групп и изображений, и поместит его в файл, указанный в следующем поле.
Имя файла фотоальбома | Указывает имя файла, в который сохранять фотоальбом (с расширением .phoa). По умолчанию подставляется имя файла текущего фотоальбома.
Описание фотоальбома | Позволяет задать описание для вновь создаваемого фотоальбома. По умолчанию подставляется описание текущего фотоальбома.
Также включить в фотоальбом существующие представления | Если включено, в созданный фотоальбом будут добавлены все представления текущего фотоальбома.
Скопировать саму программу в папку назначения | Если включено, исполняемый файл программы (phoa.exe) также будет скопирован в папку назначения. Поскольку, как известно, программа не требует инсталляции для запуска на компьютере, она может быть запущена с любого носителя, в том числе и сменного.
Скопировать текущие настройки программы в phoa.ini | Если включено, в процессе выполнения копирования/перемещения текущие настройки программы будут сохранены в файле phoa.ini в папке назначения. Это даёт возможность запускать программу со сменного носителя с сохранением всех текущих настроек на новом компьютере (если опция автозагрузки параметров из phoa.ini не отключена в настройках на этом компьютере.)
Создать файл autorun.inf Эта опция даёт возможность автоматически сгенерировать файл autorun.inf, расположенный в папке назначения. В этом случае вставка CD-ROM в компьютер будет автоматически запускать PhoA, а программа после запуска будет загружать указанный выше фотоальбом.
NB: Автозапуск сработает только в том случае, если эта функция на компьютере не отключена.
Установить метку носителя Задаёт название носителя, отображаемое в папке Мой компьютер. По умолчанию сюда подставляется Фотоальбом или наименование текущего представления.
NB:
  • Это поле является необязательным, и его можно оставить пустым. В этом случае в папке Мой компьютер будет отображаться метка диска.
  • Метка носителя отображается только в случае, когда функция автозапуска на компьютере не отключена.

ВНИМАНИЕ: содержимое папки, указанной как папка назначения, должно после записи располагаться в корневом каталоге диска!

См. также:

Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Опции удаления

Эта страница Мастера служит для задания параметров операции удаления файлов изображений.

Элементы интерфейса

Удалять в Корзину
  • Если эта опция выключена, файлы удаляются окончательно и бесповоротно.
  • Если опция включена, файлы перемещаются в Корзину (если это возможно на данном компьютере).
NB: Все производимые операции (как удачные, так и неудачные) протоколируются и их результаты могут быть впоследствии просмотрены.

См. также:

Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Процесс выполнения

Эта страница Мастера отображает процесс выполнения операций:

  • Эскиз изображения, с которым производится операция
  • Индикатор прогресса (состояния)
  • Счётчик успешно обработанных изображений
  • Счётчик сбоев при обработке

Элементы интерфейса

Прервать/Продолжить Эта кнопка позволяет прервать выполнение текущей операции и, нажатием кнопки Далее >, перейти к протоколу обработки. Когда процесс прерван, повторное нажатие этой кнопки возобновляет его.

См. также:

Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Протокол операции

Эта страница отображает последовательно все операции, произведённые с файлами изображений.

Элементы интерфейса

Отображать только ошибки | Если этот переключатель включен, список протокола отображает только сбойные записи, в противном случае показываются также записи об успешно выполненных операциях. Включить фильтрацию полезно в случае, если обрабатывалось множество файлов, из которых только немногие дали сбои.
Сохранить в файл... Позволяет записать протокол в простой текстовый файл, полезный, например, для последующего просмотра или машинной обработки.
NB:
  • При сохранении протокола сохраняются всегда все имеющиеся записи независимо от состояния переключателя Отображать только ошибки.
  • Сбойные записи в протоколе всегда имеют в начале строки последовательность символов [!], в то время как успешно добавленные начинаются с символов [+]. Это позволяет легко искать ошибки в протоколе.
Контекстное меню (доступное по нажатию правой кнопки мыши в списке) предоставляет дополнительные опции:
Копировать | Копирует текущую выбранную строку в буфер обмена.
Найти... | Отображает стандартный диалог поиска текста, позволяющий произвести поиск в списке протокола, например, какого-либо имени файла.

Вы можете просмотреть протокол до завершения обработки всех изображений, прервав процесс и нажав кнопку Далее. После этого можно (нажав Назад) вернуться к странице обработки и продолжить процесс.

См. также:

Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Редактор выражений фильтра изображений

Редактор выражений используется для ввода выражений фильтра изображений в PhoA: при поиске по выражению и в свойствах представлений.

Подробное описание языка выражений фильтра изображений приведено здесь.

Элементы интерфейса

Новое | Очищает содержимое редактора выражения.
Открыть... | Отображает стандартный диалог открытия файла, позволяющий загрузить текст выражения из сохранённого ранее файла. Кнопка со стрелкой вниз предоставляет доступ к списку последних открывавшихся и сохранявшихся файлов.
Сохранить как... | Отображает стандартный диалог сохранения файла, позволяющий выбрать файл для записи текущего выражения.
Вставить свойство | Отображает меню со списком доступных свойств изображений. При выборе пункта текст свойства вставляется в текущую позицию курсора в редакторе выражения.
Вставить оператор | Отображает меню со списком доступных операторов. При выборе пункта текст оператора вставляется в текущую позицию курсора в редакторе выражения.
Вырезать | Вырезает выделенный в редакторе выражения текст в буфер обмена.
Копировать | Копирует выделенный в редакторе выражения текст в буфер обмена.
Вставить | Вставляет текст из буфера обмена в редактор выражения.
Отменить | Отменяет последнее сделанное в редакторе выражения изменение.
Вернуть | Возвращает ошибочно отменённое в редакторе выражения изменение.
Проверить синтаксис | Производит проверку правильности написанного выражения и при наличии ошибок выдаёт соответствующее уведомление.

Эти же команды доступны также через контекстное меню редактора выражения, отображаемое при нажатии правой кнопки мыши или комбинации клавиш Shift+F10.

См. также:

Поиск изображений
Поиск изображений :: Поиск по выражению
Окно свойств представления
Представления
Выражения фильтра изображений


Сочетания клавиш и управление мышью

PhoA позволяет выполнить практически любое действие несколькими способами: выбором пункта основного меню или нажатием кнопки на панели инструментов (только в режиме обзора), нажатием сочетания клавиш на клавиатуре, выбором пункта из контекстного меню или соответствующей операцией с мышью. Ниже приводятся сочетания клавиш и управление мышью для основных режимов работы программы:

  • Режим обзора:
    • Клавиатура
    • Мышь
  • Режим просмотра:
    • Клавиатура
    • Мышь


Управление :: Режим обзора :: Клавиатура

Клавиши | Действие | Описание
Alt+Enter | Изменение | Открывает окно свойств фотоальбома или изображения, или переходит в режим редактирования имени текущей группы (зависит от текущего выделения).
Alt+Ins | Создание группы | Создаёт новую группу в текущей группе, присваивает ей имя по умолчанию и входит в режим редактирования имени.
Ctrl+A | Выделить все | Выделяет все изображения текущей группы.
Ctrl+C, Ctrl+Ins | Копировать | Копирует выделенные изображения в буфер обмена.
Ctrl+D | Снять выделение | Убирает выделение со всех изображений текущей группы.
Ctrl+End | Фокус в конец | Фокусирует последнее изображение, не изменяя текущего выделения.
Ctrl+Enter | Просмотр | Переходит в режим просмотра текущего изображения.
Ctrl+F1 | О программе | Отображает информацию о версии, авторских правах и обновлении PhoA.
Ctrl+F2 | Операции с изображениями | Вызывает диалоговое окно операций с изображениями.
Ctrl+F3 | Сортировка изображений | Открывает окно сортировки изображений.
Ctrl+G | Группы изображений | Отобразить дерево групп фотоальбома (в случае, если активно представление).
Ctrl+Home | Фокус в начало | Фокусирует первое изображение, не изменяя текущего выделения.
Ctrl+N | Создание нового фотоальбома | Очищает всю информацию о фотоальбоме, группах и изображениях.
Ctrl+O | Открытие файла фотоальбома | Открывает окно для выбора файла фотоальбома, загружает фотоальбом для обработки или просмотра.
Ctrl+Page Down | Фокус на страницу вниз | Передвигает фокус изображения на экран вниз, не изменяя текущего выделения.
Ctrl+Page Up | Фокус на страницу вверх | Передвигает фокус изображения на экран вверх, не изменяя текущего выделения.
Ctrl+R | Операции с файлами | Открывает окно Мастера операций с файлами изображений.
Ctrl+S | Сохранение файла фотоальбома | Записывает текущий фотоальбом в файл на диске.
Ctrl+V, Shift+Ins | Вставить | Добавляет изображения из буфера обмена к текущей группе (если буфер обмена содержит изображения, помещённые туда программой PhoA).
Ctrl+X, Shift+Del | Вырезать | Удаляет выделенные изображения в буфер обмена.
Ctrl+Z, Alt+Backspace | Отменить | Отменяет последнее сделанное Вами изменение.
Ctrl+Пробел | Переключить выделение эскиза | Выделяет или снимает выделение с текущего эскиза.
Ctrl+Клавиши со стрелками | Перемещение фокуса | Передвигает фокус (пунктирное выделение) изображения, не изменяя текущего выделения.
Del | Удаление | Удаляет выбранную группу или выделенные изображения после выдачи запроса (зависит от текущего выделения).
End | Последний элемент | Перемещает выделение к последней группе или изображению (в зависимости от того, какое окно активно).
Enter (когда активно окно эскизов) | Просмотр | Переходит в режим просмотра текущего изображения.
F1 | Содержание справки | Запускает Справочную систему PhoA.
F2 (когда активно дерево групп) | Переименовать | Переходит в режим редактирования имени текущей группы фотоальбома или имени представления.
F3 | Поиск | Доступ к функции поиска изображений.
F4 | Настройки программы | Открывает окно настроек программы.
F8 | Статистика | Рассчитывает и отображает статистику фотоальбома.
F12 | Сохранение фотоальбома в файл с другим именем | Открывает окно для ввода имени нового файла фотоальбома, записывает фотоальбом в выбранный файл и делает этот файл текущим.
Home | Первый элемент | Перемещает выделение к первой группе или изображению (в зависимости от того, какое окно активно).
Ins | Добавление изображения | Открывает Мастер добавления изображений в текущую группу.
Page Down | Следующая страница | Перемещает выделение на один экран вниз.
Page Up | Предыдущая страница | Перемещает выделение на один экран вверх.
Shift+Alt+Del | Удалить представление | Удаляет текущее представление.
Shift+Alt+Enter | Изменить представление | Открыть окно свойств представления.
Shift+Alt+G | Поместить представление в группу | Открыть окно выбора группы для помещения в неё представления.
Shift+Alt+Ins | Новое представление | Открыть Окно добавления представления.
Shift+Alt+Клавиши со стрелками | Выделение прямоугольной области изображений | Выделяет прямоугольную область изображений (с предыдущего до следующего текущего).
Shift+Ctrl+Enter | Просмотр слайдов | Переходит в режим просмотра текущего изображения и включает показ слайдов.
Shift+Ctrl+O | Загрузка настроек из ini-файла | Отображает диалог для выбора файла с расширением .ini, из которого нужно загрузить настройки программы.
Shift+Ctrl+S | Сохранение настроек в ini-файле | Отображает диалог для выбора файла с расширением .ini, в который требуется записать текущие настройки программы.
Shift+End | Выделение изображений до конца | Выделяет подряд изображения с текущего до самого последнего.
Shift+Home | Выделение изображений до начала | Выделяет подряд изображения с текущего до самого первого.
Shift+Page Down | Выделение изображений на страницу вниз | Выделяет подряд изображения с текущего до изображения, находящегося на один экран ниже.
Shift+Page Up | Выделение изображений на страницу вверх | Выделяет подряд изображения с текущего до изображения, находящегося на один экран выше.
Shift+Клавиши со стрелками | Выделение диапазона изображений | Выделяет подряд несколько изображений (с предыдущего до следующего текущего).
Клавиши со стрелками | Перемещение выделения | Перемещает выделение по дереву групп или списку изображений (в зависимости от того, какое окно активно).
Пробел | Выделить эскиз | Выделяет текущий эскиз.


Управление :: Режим обзора :: Мышь

Клавиши | Действие | Описание
Колёсико | Прокрутка | Прокручивает дерево групп или список изображений (в зависимости от того, какое окно активно).
Ctrl+Колёсико | Поэкранная прокрутка | Прокручивает список изображений — на один экран за щелчок.
Щелчок левой кнопкой | Одиночное выделение | Выделяет одну группу или изображение (в зависимости от того, какое окно активно).
Щелчок правой кнопкой | Контекстное меню | Вызывает контекстное меню.
Ctrl+Щелчок левой кнопкой | Выделение отдельных изображений | Выделяет или снимает выделение с одиночного изображения.
Shift+Щелчок левой кнопкой | Выделение диапазона изображений | Выделяет подряд несколько изображений (с предыдущего выбранного до того, на котором щёлкнули).
Ctrl+Щелчок правой кнопкой | Системное контекстное меню | Вызывает системное контекстное меню (меню Проводника) для файла изображения, на котором щёлкнули.
Нажатие левой кнопки и смещение в свободной от изображений области, Alt+Нажатие левой кнопки и смещение | Выделение прямоугольной области | Рисует рамку группового выделения изображений (в виде прямоугольника).
Shift+Alt+Нажатие левой кнопки и смещение | Добавление к выделению прямоугольной области | Дополняет текущее выделение рамкой группового выделения изображений.
Перетаскивание выделенных изображений при нажатой левой кнопке внутри окна | Упорядочивание изображений | Перемещает выделенные изображения в точку вставки.
Перетаскивание выделенных изображений при нажатой левой кнопке в одну из групп | Перемещение изображений | Перемещает выделенные изображения из текущей группы в другую группу. Отображает информацию о том, сколько реально изображений было перенесено, если это включено в настройках программы.
Ctrl+Перетаскивание выделенных изображений при нажатой левой кнопке в одну из групп | Копирование изображений | Копирует выделенные изображения в другую группу. Отображает информацию о том, сколько реально изображений было скопировано, если это включено в настройках программы.
Двойной щелчок по узлу дерева групп | Свернуть/развернуть | Сворачивает или разворачивает узел дерева.
Двойной щелчок по изображению | Режим просмотра | Перейти в режим просмотра выбранного изображения.


Управление :: Режим просмотра :: Клавиатура

Клавиши | Действие | Описание
Alt+Enter | Изменить | Открывает окно свойств текущего отображаемого изображения.
Ctrl+I | Перемещение поля информации | Отображает маркеры вокруг строки информации, позволяющие перемещать и изменять её размер. Повторное нажатие или нажатие мышью вне поля завершает режим.
Ctrl+Клавиши со стрелками | Быстрая прокрутка изображения | Быстро прокручивает изображение в заданном направлении (если оно не вписывается в окно).
End | Последнее изображение | Переход к просмотру последнего изображения.
Enter | Завершить просмотр на текущем изображении | Аналогично Esc возвращает программу в режим обзора, но выделяет в окне просмотра эскизов последнее просмотренное изображение.
Esc | Завершить просмотр | Возвращает программу в режим обзора, не меняя последнего выделения в окне эскизов.
F | Полноэкранный / Оконный режим | Переключает режим отображения из полноэкранного в оконный и обратно.
F1 | Справка | Отображает справку по режиму просмотра.
F2 | Отображение информации | Отображает или скрывает строку информации.
F4 | Настройки программы | Открывает окно настроек программы.
F5 | Перегрузить изображение | Перечитывает текущее изображение из файла.
Home | Первое изображение | Переход к просмотру первого изображения.
Page Up, BackSpace | Предыдущее изображение | Переход к просмотру предыдущего изображения.
Page Down, Space | Следующее изображение | Переход к просмотру следующего изображения.
Pause | Включить/выключить показ слайдов | Активизирует или деактивизирует автоматический показ слайдов. Параметры просмотра слайдов задаются в настройках режима просмотра.
Shift+Клавиши со стрелками | Точная прокрутка изображения | Медленно прокручивает изображение в заданном направлении (если оно не вписывается в окно).
+ (цифровая клавиатура) | Увеличить | Увеличивает изображение на величину, указанную в настройках режима просмотра.
- (цифровая клавиатура) | Уменьшить | Уменьшает изображение на величину, указанную в настройках режима просмотра.
* (цифровая клавиатура) | Наилучшее соответствие окну | Масштабирует изображение так, чтобы оно точно вписалось в окно.
/ (цифровая клавиатура) | Масштаб 1:1 | Отображает изображение в масштабе 1:1 (когда каждый пиксел изображения соответствует одному пикселу на экране).
Клавиши со стрелками | Прокрутка изображения | Прокручивает изображение в заданном направлении (если оно не вписывается в окно).


Управление :: Режим просмотра :: Мышь

Клавиши | Действие | Описание
Колёсико вниз | Следующее изображение | Переход к просмотру следующего изображения.
Колёсико вверх | Предыдущее изображение | Переход к просмотру предыдущего изображения.
Щелчок средней кнопкой, Щелчок колёсиком | Полноэкранный / Оконный режим | Переключает режим отображения из полноэкранного в оконный и обратно.
Щелчок правой кнопкой | Контекстное меню | Вызывает контекстное меню.
Ctrl+Щелчок правой кнопкой | Системное контекстное меню | Вызывает системное контекстное меню (меню Проводника) для текущего отображаемого файла изображения.
Ctrl+Колёсико вверх | Увеличить | Увеличивает изображение на величину, указанную в настройках режима просмотра.
Ctrl+Колёсико вниз | Уменьшить | Уменьшает изображение на величину, указанную в настройках режима просмотра.
Перетаскивание при нажатой левой кнопке | Прокрутка изображения | Прокручивает изображение в заданном направлении (если оно не вписывается в окно).


Преобразования

Данная версия PhoA поддерживает так называемые недеструктивные преобразования, то есть преобразования, не изменяющие исходных файлов изображений. Такие преобразования выполняются непосредственно перед просмотром изображения, в памяти.

Заданные преобразования всегда выполняются в определённом порядке:

  1. Поворот
  2. Отражения

Вы можете применять преобразования как при просмотре изображения, так и заранее, в диалоге свойств изображения. Кроме того, заданные при просмотре преобразования могут быть записаны в свойства изображения с помощью команды Записать преобразования.

Преобразования, сохранённые в свойствах изображения, влияют также и на отображение эскиза этого изображения - к нему применяются те же преобразования.

Поворот

Программа позволяет поворачивать изображения на угол, кратный 90°. Это позволяет, например, просматривать изображения, снятые камерой, повёрнутой относительно исходного положения.

Отражения

Реализованы два варианта отражения: горизонтальное (вдоль вертикальной оси изображения) и вертикальное (вдоль горизонтальной оси).

См. также:

Режим просмотра
Свойства изображения :: Просмотр и настройка


Параметры командной строки

PhoA поддерживает задание ряда параметров в командной строке. Общий формат командной строки программы таков:

phoa.exe [ключ1 [значение_ключа1] [ключ2 [значение_ключа2]] ... ] [файл_фотоальбома],

где:

  • ключN — символ, перед которым стоит знак - ("минус"). Список допустимых ключей см. ниже.
  • значение_ключаN — строка символов, определяющая значение ключа. Некоторые ключи не допускают указания значения, некоторые его обязательно требуют. Остальные, соответственно, допускают необязательное значение.
  • файл_фотоальбома — необязательный файл фотоальбома, загрузка которого произойдёт при запуске программы.

Допустимые ключи

-w имя_представления | Активизировать представление имя_представления. Если данный ключ не указан, после запуска программа по умолчанию отображает группы изображений. Поиск представления по имени осуществляется без учёта регистра. Пример: -w "По дате и месту"
-g путь_группы | Выбрать в дереве группу, заданную параметром путь_группы. Путь группы представляет собой строку наподобие пути файла в файловой системе, с тем отличием, что для разделения каталогов используется символ / ("слэш"). В начале пути можно указывать, а можно и не указывать символ / — на результат это не влияет. Может быть указана как обычная группа, так и группа представления (т.е. в сочетании с ключом -w). Если данный ключ не указан, программа по умолчанию выделяет корневой элемент дерева групп. Поиск групп по имени осуществляется без учёта регистра. Пример: -g "Фотографии по дате/2000 г./Январь/Утро"
-i ID_изображения | Выделить в окне эскизов изображение с заданным ID. Если данный ключ не указан, программа по умолчанию выделяет самый первый эскиз в текущей группе. Пример: -i 418
-v | После запуска перейти в режим просмотра. Переход в режим просмотра доступен только при наличии выделенного изображения.
-s | Имеет смысл только в сочетании с -v. Если указан, программа после перехода в режим просмотра запустит показ слайдов.
-f [1|0] | Имеет смысл только в сочетании с -v и задаёт полноэкранный или оконный режим. Если данный ключ не указан, то программа использует текущие настройки для выбора полноэкранного/оконного режима. Если ключ указан без значения или со значением 1 (единица), то принудительно устанавливается полноэкранный режим режима просмотра (только для текущей сессии). Если ключ указан со значением 0 (ноль), то принудительно устанавливается оконный режим режима просмотра (также только для текущей сессии). Примеры: -f -f 0
NB:
  • Параметры в командной строке разделяются пробелами.
  • Если значение параметра или имя файла фотоальбома содержат пробелы, их необходимо заключать в двойные кавычки, как в вышеприведённых примерах.
  • Имя файла фотоальбома можно указывать в любом месте командной строки после имени программы. Необходимо обеспечить, однако, чтобы программа не восприняла его в качестве значения параметра: например, писать его в начале строки параметров или же после значения параметра (так как значение у параметра может быть только одно).
  • Ошибки в задании параметров командной строки отображаются при запуске программы.


Метаданные

Файлы изображений могут содержать кроме собственно графической информации дополнительные (текстовые) данные, называемые метаданными. Такие метаданные, например, помещаются в изображения практически всеми цифровыми фотоаппаратами, и содержат, чаще всего, информацию о дате и времени съёмки, данные об условиях съёмки (ориентацию камеры, использование вспышки, фокусное расстояние и экспозиция) и т. д.

Впоследствии эти данные могут быть просмотрены и даже изменены некоторыми программами, а в целом они представляют собой достоверный и ценный источник информации об изображении, к тому же содержащийся непосредственно в его файле и всегда его сопровождающий.

NB: Значительной и не вполне очевидной проблемой является то, что изображения открываются практически любыми программами, независимо от того, содержатся в них метаданные или нет, а также от того, поддерживают ли эти программы вообще метаданные или нет — формат файла изображения это позволяет. Подвох состоит в том, что вы можете открыть изображение какой-нибудь не очень умной программой просто для того, чтобы, скажем, развернуть изображение на 90°, и сохранить его. Если эта программа не поддерживает метаданных, то вы просто потеряете их, переписав файл. Не пользуйтесь глупыми программами!

Начиная с версии 1.1.1a, PhoA тоже резко поумнел, и теперь программа поддерживает метаданные в спецификации EXIF 2.2 - формат метаданных для файлов JPEG. Считанные метаданные могут быть просмотрены, а также могут быть использованы для автозаполнения свойств изображений (при соответствующей настройке).

Кроме того, чтобы поспособствовать появлению умных и образованных программ (хотя бы написанных на Delphi), я решил опубликовать на сайте PhoA исходные коды модуля, осуществляющего чтение метаданных.


Ресэмплинг

Изображения часто выглядят "мохнатыми" после масштабирования в другой размер. "Мохнатость" изображения определяется двумя процессами: ресэмплингом и фильтрацией.

Процесс фильтрации делает попытку смягчить (размыть) преобразуемые пикселы. Когда изображение подвергается ресэмплингу в другой размер, возникает необходимость в интерполяции старой сетки пискселов в новую. Эта интерполяция может быть выполнена несколькими методами. Самый простой и быстрый метод — метод функции "ближайшего соседа" (nearest neighbor). При небольших изменениях размеров изображения этого метода вполне достаточно. Однако при большом увеличении картинки пикселы превращаются в большие квадраты; при сильном уменьшении возникает эффект алиасинга, который и проявляется в "мохнатости" изображения. В таких случаях можно использовать более точные методы интерполяции, которые, однако, требуют больше времени на обработку изображения. Наиболее часто используемые интерполяционные фильтры — это nearest neighbor, билинейный и B-сплайновый (в порядке возрастания точности). Полный список реализованных в PhoA фильтров таков:

  • Nearest neighbor (метод "ближайшего соседа");
  • Draft;
  • Linear (билинейная интерполяция);
  • Cosine;
  • B-spline (B-сплайн или бикубическая интерполяция);
  • Lanczos;
  • Mitchell.


Маски файлов

Маски файлов — это шаблоны для проверки имён файлов, составляемые по определённым правилам.

PhoA использует маски файлов в многих местах: при поиске, при задании фильтра добавления файлов изображений, при описании инструментов и пр.

Правила составления масок файлов

  • В программе используются списки масок, разделённые символом точки с запятой (;). Правила составления каждой из масок см. ниже. Файл считается соответствующим маскам, если он подходит под любую из заданных в списке масок (условие логического ИЛИ).
  • Допустимая маска (каждый из элементов списка, разделённых символом ";") состоит из необязательного символа отрицания, символов, наборов и шаблонов (специальных символов).
  • Символ отрицания представляет собой восклицательный знак (!), помещённый в начало маски. Если он присутствует, значение маски меняется на противоположное, т.е. файлы, соответствующие маске считаются не соответствующими, и наоборот. Каждая маска в списке масок может иметь или не иметь отрицания, каждое отрицание распространяется лишь на маску, которая непосредственно следует за ним.
  • Каждый символ, встречаемый в тексте маски, должен соответствовать символу в имени файла.
  • Каждый набор начинается с открывающей квадратной скобки ([), и завершается закрывающей квадратной скобкой (]). Между скобками находятся элементы набора. Каждый элемент — это символ или диапазон символов. Диапазоны задаются начальным значением, чёрточкой (символом минуса, "-") и конечным значением. Не допускается использования пробелов или запятых для разделения элементов набора. Каждый набор соответствует одиночному символу в проверяемой строке. Символ считается подходящим, если он совпадает с любым из символов набора или входит в любой из диапазонов набора, т.е. совпадает с начальным его значением, конечным значением или попадает в диапазон между ними.
    Если первый символ в наборе (после открывающей квадратной скобки) — это восклицательный знак (!), то смысл набора меняется на противоположный, и символ проверяемой строки считается подходящим, если он не попадает в набор.
  • Шаблоны (или джокеры, wildcards) — это символы вопросительного знака (?) и звёздочки (*).
    Вопросительный знак означает любой одиночный символ.
    Звёздочка означает произвольное количество любых символов (в том числе и отсутствие символов).
NB:
  • Сравнение символов в масках всегда регистронезависимое (т.е. заглавные и строчные буквы не различаются).
  • В тех местах, где это допускается, пустая маска (не содержащая символов) означает соответствие любому файлу.

Примеры масок

  • * — любой файл;
  • *.* — любой файл, имеющий расширение;
  • *.jpg — файл с любым именем и расширением .jpg;
  • vacation.* — файл с именем vacation и любым расширением;
  • [a-z]*.jpg — файл с именем, начинающимся с латинской буквы и расширением .jpg;
  • [!a-z]* — файл с именем, начинающимся не с латинской буквы
  • *.jpg;*.gif;*.png;!temp* — все файлы с расширениями .jpg, .gif, .png, а также файлы, чьё имя начинается не на "temp".

См. также:

Поиск
Инструменты


Выражения фильтра изображений

Выражения фильтра изображений используются при поиске изображений по выражению, в свойствах представления и позволяют задавать сколь угодно сложные критерии поиска на специальном языке, чем-то напоминающем современные языки программирования.

Для их редактирования в PhoA используется стандартный редактор выражений.

Описание языка выражений фильтра

Язык выражений фильтра является регистронезависимым; выражение фильтра может быть сколь угодно большим и занимать любое количество строк.

Выражение фильтра должно возвращать логическое значение: Истина или Ложь. Если результатом его вычисления будет Истина, то изображение считается подходящим и проходит через фильтр; иначе оно пропускается.

Выражение фильтра составляется из следующих элементов: свойств изображений, операторов, скобок, констант, комментариев.

Свойства изображений

Свойства изображений всегда начинаются с символа $ и соответствуют реальным данным изображений, подставляемым в процессе фильтрации (или поиска):
Имя | Тип данных | Свойство
$ID | Integer (целое число) | ID (уникальный идентификатор) изображения
$FileName | String (строка) | Имя файла изображения
$FullFileName | String (строка) | Имя и путь к файлу изображения
$FilePath | String (строка) | Путь к файлу изображения
$FileSize | String (строка) | Размер файла изображения
$FileSizeBytes | Integer (целое число) | Размер файла изображения в байтах
$PicWidth | Integer (целое число) | Ширина изображения в пикселах
$PicHeight | Integer (целое число) | Высота изображения в пикселах
$PicDims | Size (размеры) | Размеры изображения в пикселах
$ThumbWidth | Integer (целое число) | Ширина изображения эскиза в пикселах
$ThumbHeight | Integer (целое число) | Высота изображения эскиза в пикселах
$ThumbDims | Size (размеры) | Размеры изображения эскиза в пикселах
$Format | Pixel Format (пиксельный формат) | Пиксельный формат изображения
$Date | Date (дата) | Дата
$Time | Time (время) | Время
$Place | String (строка) | Место
$FilmNumber | String (строка) | Номер/название плёнки
$FrameNumber | String (строка) | Номер кадра
$Author | String (строка) | Автор
$Description | String (строка) | Описание
$Notes | String (строка) | Примечание
$Media | String (строка) | Имя/код носителя
$Keywords | String List (список строк) | Ключевые слова
$Rotation | Rotation (поворот) | Поворот
$Flips | Flips (отражения) | Отражения

Операторы

Операторы бывают двух видов:

  • Унарные операторы — это операторы, имеющие один операнд, расположенный справа от него.
    Примеры: not, isEmpty.
  • Бинарные операторы — операторы, имеющие два операнда слева и справа от него.
    Примеры: and, contains, >.

Операторы могут применяться только к операндам, имеющим определённый тип данных, зависящий от конкретного оператора.

В текущей версии программы реализованы следующие операторы:
Имя | Тип | Синтаксис | Описание и примеры
and | Бинарный | expression1 and expression2 | Логическое И. Возвращает значение Истина, если оба выражения expression1 и expression2 истинны; иначе возвращает Ложь. Пример: $Author='Вася Пупкин' and $Date>'01.04.2001'
or | Бинарный | expression1 or expression2 | Логическое ИЛИ. Возвращает значение Истина, если любое из выражений expression1 или expression2 истинно; иначе возвращает Ложь. Пример: $Place contains 'сарай' or $Description='Бахчисарай'
not | Унарный | not expression | Логическое отрицание. Если выражение expression истинно, возвращает Ложь и наоборот. Пример: not ('попугай' in $Keywords)
in | Бинарный | element in list | Проверка наличия элемента в списке. Возвращает значение Истина, если элемент element присутствует в списке list; иначе возвращает Ложь. Пример: 'попугай' in $Keywords
startsWith | Бинарный | string startsWith substring | Возвращает значение Истина, если строка string начинается с подстроки substring; иначе возвращает Ложь. Пример: $Place startsWith 'город'
endsWith | Бинарный | string endsWith substring | Возвращает значение Истина, если строка string оканчивается на подстроку substring; иначе возвращает Ложь. Пример: $Place endsWith 'сарай'
contains | Бинарный | string contains substring | Возвращает значение Истина, если строка string содержит подстроку substring; иначе возвращает Ложь. Пример: $Description contains 'крокодил'
isEmpty | Унарный | isEmpty list | Возвращает значение Истина, если список list пуст (не содержит элементов); иначе возвращает Ложь. Пример: isEmpty $Keywords
= | Бинарный | expression1=expression2 | Возвращает значение Истина, если значение выражения expression1 равно значению выражения expression2; иначе возвращает Ложь Пример: $PicWidth=1024
<> | Бинарный | expression1<>expression2 | Возвращает значение Истина, если значение выражения expression1 не равно значению выражения expression2; иначе возвращает Ложь. Пример: $Notes<>''
< | Бинарный | expression1<expression2 | Возвращает значение Истина, если значение выражения expression1 меньше значения выражения expression2; иначе возвращает Ложь. Пример: $ThumbWidth<$ThumbHeight
<= | Бинарный | expression1<=expression2 | Возвращает значение Истина, если значение выражения expression1 меньше или равно значению выражения expression2; иначе возвращает Ложь. Пример: $ThumbWidth<=100
> | Бинарный | expression1>expression2 | Возвращает значение Истина, если значение выражения expression1 больше значения выражения expression2; иначе возвращает Ложь. Пример: $ThumbWidth>$ThumbHeight
>= | Бинарный | expression1>=expression2 | Возвращает значение Истина, если значение выражения expression1 больше или равно значению выражения expression2; иначе возвращает Ложь. Пример: $ThumbWidth>=100

Скобки

Скобки служат для группировки отдельных частей выражения и изменения порядка их вычисления. В выражениях могут использоваться только круглые скобки: ( и ). Например:
not (isEmpty $Keywords or ($Author startsWith 'Вася') or ($Description='' and $PicWidth=$PicHeight))

Константы

Константы в выражениях могут быть следующих типов:

  • Целочисленные константы могут состоять из цифр 0...9 и знака "минус" (-). Например:
    -123
  • Вещественные константы состоят из цифр 0...9, знака - и десятичной точки (.). Например:
    -123.45
  • Строковые константы или литералы заключаются в одинарные кавычки (') и могут содержать любые символы. Если внутри строки необходимо вставить символ одинарной кавычки, его необходимо продублировать. Например:
    'Однажды в студёную'
    'Don''t get me wrong'
  • Константы даты пишутся так же, как и литералы, но их формат должен совпадать с текущими установками формата даты в системе. Например:
    '25.07.2003'
  • Константы времени пишутся так же, как и литералы, но в формате "Часы:Минуты" или "Часы:Минуты:Секунды". Например:
    '12:00:03'

Комментарии

Коментарии игнорируются при разборе выражения и служат для пояснения отдельных частей выражения или для временного их "отключения". Программа поддерживает следующие виды комментариев:

  • Поточный комментарий {comment}: комментарием считаются все символы с первого символа { и до первого символа }. Например:
    $Date>'01.01.1914' { это дата рождения моей прабабушки } or $Author<>'бабушка'
  • Строчный комментарий //comment: комментарием считаются все символы, начиная с последовательности // и до конца текущей строки. Например:
    $Date>'01.01.1914' // это дата рождения моей прабабушки
    or $Time<'08:00'

См. также:

Поиск изображений
Поиск изображений :: Простой поиск
Поиск изображений :: Поиск по выражению
Данные изображений


Инструменты

Инструмент в PhoA — это определяемая (и настраиваемая) пользователем команда. Инструменты обладают следующими характеристиками:

  • Они бывают разного вида.
  • Они применимы к файлам, подходящим под заданные маски.
  • Они отображаются в меню; в каких именно — определяется установленными флагами использования инструмента.
  • Они доступны, только если есть выделенные изображения.
  • Они имеют наименование и подсказку (кроме пункта-разделителя). Наименование отображается в меню, а подсказка — в строке состояния при выборе пункта меню.

Виды инструментов

Текущая версия PhoA поддерживает следующие виды инструментов:

  • Пункт-разделитель
  • Действие по умолчанию
  • Стандартное действие "Открыть"
  • Стандартное действие "Изменить"
  • Стандартное действие "Печать"
  • Заданное действие

Пункт-разделитель

Представляет собой статический разделитель в меню.

Действие по умолчанию

Выполняет действие, которое по умолчанию установлено для типа файла, к которому инструмент применяется.

Стандартное действие "Открыть"

Выполняет действие Открыть (open), которое установлено для типа файла, к которому инструмент применяется.

Стандартное действие "Изменить"

Выполняет действие Изменить (edit), которое установлено для типа файла, к которому инструмент применяется.

Стандартное действие "Печать"

Выполняет действие Печать (print), которое установлено для типа файла, к которому инструмент применяется.

NB: Действие по умолчанию и стандартные действия задаются с помощью диалога Свойства папки меню Сервис Проводника Windows (закладка Типы файлов).

Заданное действие

Вы сами задаёте приложение и параметры его вызова в Диалоге свойств инструмента.

Маски файлов

Инструмент становится доступным (или отображаемым, в случае с разделителем) лишь тогда, когда все выделенные изображения подходят под его список масок — если хотя бы один из файлов не подходит, инструмент скрывается. Это позволяет настраивать список инструментов под обработку лишь файлов определённого типа.

Правила составления масок описаны здесь.

NB: Пустая маска инструмента (не содержащая символов) означает применимость его к любому файлу.

Использование инструмента

Инструменты в PhoA отображаются в различных меню. Вы можете настроить сами, где именно будет создан пункт для вызова действия, выполняемого инструментом:

  • В меню Сервис: команда отображается в подменю Сервис главного меню.
  • В контекстном меню окна групп изображений: команда появляется в меню дерева групп, вызываемом нажатием правой кнопки мыши.
  • В контекстном меню окна эскизов: команда появляется в меню окна просмотра эскизов, вызываемом нажатием правой кнопки мыши.
  • В контекстном меню режима просмотра: команда появляется в контекстном меню, вызываемом нажатием правой кнопки мыши в режиме просмотра.

Если в момент вызова команды инструмента было активно окно групп изображений, инструмент применяется ко всем изображениям группы. Если же было активно окно эскизов, то инструмент применяется к выделенным изображениям.

Порядок следования пунктов инструментов в меню определяется их порядком в редакторе инструментов.

См. также:

Настройки программы :: Инструменты
Настройки программы


FAQ (часто задаваемые вопросы)

Оглавление

  • Я прочитал и понял всю документацию программы. Но как (в конце концов) мне создать фотоальбом???
  • Как изменить язык интерфейса?
  • Как мне изменить размер эскизов, используемых в программе?
  • Как можно улучшить качество эскизов?
  • Могу ли я записать созданный фотоальбом на CD-ROM вместе с программой — так, чтобы его можно было бы просмотреть на любом компьютере?
  • Как должен выглядеть файл autorun.inf, чтобы фотоальбом на CD-ROM запускался автоматически?
  • Я хочу, чтобы при запуске программы автоматически открывался мой фотоальбом. Как?
  • Можно ли изменить путь к изображениям фотоальбома?

Вопросы и ответы

Я прочитал и понял всю документацию программы. Но как (в конце концов) мне создать фотоальбом???

Это проще, чем может показаться:

  • Вы можете создать несколько папок-групп для изображений. Делается это выбором пункта меню Правка | Добавить группу или нажатием Alt+Ins — при этом группа добавляется "внутри" текущей выделенной группы. Этот шаг можно пропустить и добавлять изображения непосредственно в фотоальбом.
  • Выделите папку в дереве, в которую будут добавляться изображения (группу или сам фотоальбом).
  • Выберите пункт меню Правка | Добавить изображения.... Откроется Мастер добавления изображений.
  • На первой странице Мастера выберите папку, содержащую файлы изображений. Если в ней есть вложенные папки с изображениями, включите переключатель Загружать папки вместе с подпапками. Нажмите Далее >.
  • На странице отметки файлов можно выбрать, какие именно файлы из перечисленных требуется добавить в фотоальбом. По умолчанию отмечены все файлы. Нажмите Далее > — начнётся добавление изображений.
  • После добавления программа либо закроет окно Мастера и Вы увидите свои изображения, либо отобразит страницу с протоколом добавления (в этом случае нажмите Закрыть) — в зависимости от настроек.
  • Сохраните фотоальбом в файл. Всё!

В начало

Как изменить язык интерфейса?

Изначальный язык интерфейса определяется языком, выбранным при установке программы. Изменить его можно, выбрав пункт меню Сервис | Настройки программы... -> Вкладка Общие -> Язык интерфейса (Tools | Program settings... -> Вкладка General -> Interface language)

В начало

Как мне изменить размер эскизов, используемых в программе?

Каждый фотоальбом может иметь собственный размер эскизов. Эти данные сохраняются вместе с фотоальбомом; их можно изменить, выделив узел фотоальбома в дереве групп и выбрав пункт меню Правка | Изменить...

В начало

Как можно улучшить качество эскизов?

На качество эскизов влияют два фактора:

  • Используемый метод ресэмплинга. Метод Nearest Neighbor является самым быстрым, но изображения, уменьшенные с его помощью, выглядят "мохнатыми". Наиболее плавные контуры даёт B-spline, потом Linear. Наиболее чёткие линии на уменьшенных изображениях обеспечивает Lanczos. Изменить способ ресэмплинга можно в настройках программы (Сервис | Настройки программы... -> Режим обзора -> Метод ресэмплинга эскизов).
  • Уровень сжатия. Эскизы хранятся в формате JPEG; этот формат позволяет сжимать изображения ценой некоторой потери качества. Соотношение "размер-качество" можно задавать для каждого фотоальбома индивидуально. Изменить уровень сжатия (качество эскиза) можно, выделив узел фотоальбома в дереве групп и выбрав пункт меню Правка | Изменить...

В начало

Могу ли я записать созданный фотоальбом на CD-ROM вместе с программой — так, чтобы его можно было бы просмотреть на любом компьютере?

Да, программа PhoA специально была спроектирована так, чтобы фотоальбомы можно было записать на сменный носитель вместе с самим средством просмотра:

  • В файле фотоальбома всегда по возможности сохряняются относительные ссылки на файлы изображений (относительно файла фотоальбома). Абсолютные ссылки сохраняются только для тех изображений, файлы которых находятся на другом диске, чем файл фотоальбома, или на сетевом сервере. Это даёт возможность записать на диск изображения и фотоальбом, сохранив неизменным их взаимное расположение. Например:
    • До записи: файл фотоальбома: C:\Мои документы\Фотоальбом.phoa; базовый каталог файлов изображений: C:\Мои документы\Изображения
    • После записи (на CD-ROM): файл фотоальбома: D:\Фотоальбом.phoa; базовый каталог файлов изображений: D:\Изображения
  • Программа PhoA не требует для своего запуска никаких дополнительных файлов, кроме собственно исполняемого файла phoa.exe. Его можно разместить в любом каталоге компакт-диска.
  • Чтобы при запуске программа отображала заданный фотоальбом, нужно путь к его файлу указать в командной строке, например: phoa.exe Фотоальбом.phoa
  • Наиболее простым и эффективным способом подготовки файлов для записи на сменный носитель является использование операции копирования файлов.

В начало

Как должен выглядеть файл autorun.inf, чтобы фотоальбом на CD-ROM запускался автоматически?

Простейший вариант файла autorun.inf (создаётся любым текстовым редактором и при записи помещается в корневой каталог CD-ROM-диска):

[autorun]
open=phoa.exe Фотоальбом.phoa
icon=phoa.exe,1
label=Мой фотоальбом
Этот пример подразумевает, что исполняемый файл программы (phoa.exe) и файл фотоальбома (Фотоальбом.phoa) находятся в корневом каталоге диска (так же, как и сам autorun.inf).
Строка icon= указывает файл, содержащий значок, отображаемый в "Моём компьютере", а также индекс значка в этом файле (значки нумеруются с нуля). Для файла phoa.exe:
0 — значок самой программы;
1 — значок файла фотоальбома.
Строка label= задаёт метку устройства, отображаемую в "Моём компьютере". За более подробной информацией обращайтесь к документации MSDN.
NB: Можно воспользоваться функцией создания файла autorun.inf Операции копирования файлов.

В начало

Я хочу, чтобы при запуске программы автоматически открывался мой фотоальбом. Как?

Для этого Вы должны запускать не программу, а непосредственно сам файл фотоальбома. Например, создайте на рабочем столе ярлык к своему фотоальбому C:\Мои документы\Фотоальбом.phoa, и при запуске его сначала будет загружаться PhoA, потом программа загрузит этот фотоальбом.

В начало

Можно ли изменить путь к изображениям фотоальбома?

Во-первых, вы можете перемещать файлы изображений вместе с файлом фотоальбома, сохранив неизменным их взаимное расположение (см. запись на CD).
Во-вторых, вы можете изменять расположение файлов с помощью операции перемещения файлов.
И в-третьих, можно сменить файл изображения непосредственно, используя кнопку Изменить файл... на странице Свойства файла окна свойств изображения.

В начало


Настройки программы

Это окно служит для изменения различных настроек программы. Чтобы отобразить его, выберите пункт меню Сервис | Настройки программы... или нажмите клавишу F4.

Окно содержит несколько страниц, переключаемых с помощью панели кнопок в левой части диалога, или нажатием комбинаций клавиш Ctrl+Цифра:
Страница | Комбинация клавиш | Назначение
Общие | Ctrl+1 | Общие настройки программы
Режим обзора | Ctrl+2 | Настройки программы, касающиеся режима обзора
Режим просмотра | Ctrl+3 | Настройки программы, касающиеся режима просмотра изображений
Диалоги | Ctrl+4 | Настройки диалоговых окон и мастеров
Инструменты | Ctrl+5 | Редактор инструментов

См. также:

Режим обзора
Режим просмотра
Инструменты
Хранение настроек программы в файле


Настройки программы :: Общие

Интерфейс
Язык интерфейса | Язык всего интерфейса программы.
Шрифт программы | Базовый шрифт, используемый во всех окнах PhoA.
Визуальная тема | Позволяет выбрать одну из тем визуального оформления панелей инструментов и строки состояния.
Продолжительность отображения всплывающих подсказок | Длительность отображения подсказок в миллисекундах.
Длина списка последних открывавшихся файлов | Количество запоминаемых имён файлов, выводимое в меню Файл и в списке кнопки Открыть...
Загружать настройки из phoa.ini при его наличии в каталоге программы | Если включено, PhoA пытается найти файл phoa.ini в каталоге программы. Если файл существует, программа загружает настройки из него. Это поведение может оказаться полезным, когда программа расположена на сменном носителе, например, на CD-ROM, и запускается непосредственно с него на разных компьютерах. Подробнее о хранении настроек в файле.
Буфер обмена
Форматы, помещаемые в буфер при копировании | Набор переключателей позволяет определить форматы, используемые при работе с буфером обмена.
Панели инструментов
Размер кнопок основной панели | Регулирует размер кнопок основной панели инструментов.
Перетаскивание панелей | Определяет режим перетаскивания/встраивания панелей инструментов.
Деревья/списки
Анимация сворачивания/разворачивания | Если включено, операции сворачивания и разворачивания узлов дерева используют анимацию.
Панорамирование нажатием средней кнопки мыши | Если включено, при нажатии средней кнопки мыши в списке появляется индикатор панорамирования, при этом можно плавно прокручивать содержимое окна, откатив мышь в нужную сторону от этого индикатора.
Центрирование выделения | Если включено, программа будет пытаться всегда прокручивать списки так, чтобы выделенный пункт находился в центре окна списка.
Поиск при наборе текста | Если включено, выделение в списках автоматически сдвигается на узел, если вы набираете его текст.
Задержка сброса набора для поиска | Задаёт время в миллисекундах, в течение которого последовательные нажатия клавиш считаются относящимися к одному циклу поиска.
Вид кнопок сворачивания/разворачивания | Позволяет выбрать разновидность кнопок сворачивания/разворачивания узлов дерева (только на не-WindowsXP-системах).
Вид переключателей в узлах | Позволяет выбрать разновидность переключателей в узлах дерева там, где они есть (только на не-WindowsXP-системах).
Вид рамки выделения | Позволяет выбрать тип отрисовки рамки множественного выделения в списках (только на не-WindowsXP-системах).

См. также:

Настройки программы :: Режим обзора
Настройки программы :: Режим просмотра
Настройки программы :: Диалоги
Настройки программы :: Инструменты
Хранение настроек программы в файле


Настройки программы :: Режим обзора

Деревья групп изображений
Всплывающие описания Определяет использование всплывающих подсказок (tooltips) в деревьях, отображающих группы изображений:
  • Не отображать — подсказки отключены.
  • Отображать, если строка не помещается в окне — подсвечивает подсказкой пункты, не помещающиеся в окне — так, чтобы их было видно целиком.
  • Отображать с выбранными свойствами — используются всплывающие подсказки, в которых отображаются выбранные свойства групп (см. ниже). Кроме того, в этом режиме для узла фотоальбома выводится в виде подсказки его описание.
Отображать во всплывающих описаниях | Список свойств, из которого Вы можете выбрать, какие свойства групп отображать во всплывающих подсказках. Имеет смысл только когда для подсказок выбран режим Отображать с выбранными свойствами.
Окно просмотра эскизов
Цвет фона | Задаёт цвет фона окна эскизов.
Цвет фона эскиза | Задаёт цвет фона отдельных эскизов.
Цвет шрифта эскиза | Задаёт цвет шрифта надписей эскизов.
Drag'n'Drop | Разрешает или запрещает перетаскивание изображений из окна эскизов.
Показывать всплывающие описания эскизов | Эта функция разрешает отображать всплывающие подсказки (tooltips), если остановить мышь над эскизом. Эти подсказки отображают свойства изображения (см. ниже). Вообще-то полезная функция, но некоторых раздражает.
Отображать во всплывающих описаниях | Список свойств, из которого Вы можете выбрать, какие свойства изображений отображать во всплывающих описаниях эскизов.
Данные, отображаемые на эскизах | С помощью этих опций Вы можете выбрать отображать ли и какие именно из свойств изображений в каждом из четырёх углов эскиза.
Стиль рамки фона эскиза | Определяет стиль рамки прямоугольника, на котором отображаются изображение и описание эскиза в окне эскизов.
Пользовательский цвет рамки фона эскиза | Если опция Стиль рамки фона эскиза установлена в Цвет, заданный пользователем, то цвет, указанный в данной настройке, используется для отрисовки границы прямоугольника эскиза.
Отображать тень эскиза | Если включена, под изображением эскиза рисуется тень с параметрами, указанными ниже.
Радиус размывки тени | Радиус "пятна", используемого для отрисовки тени, в пикселах.
Горизонтальное/вертикальное смещение тени | Смещение тени в пикселах относительно изображения эскиза.
Цвет тени | Цвет, используемый для отрисовки тени эскиза. По умолчанию — чёрный.
Непрозрачность тени | Значение в диапазоне 0...255, задающее уровень "непрозрачности" тени эскиза.
Метод ресэмплинга эскизов | Определяет интерполяционный фильтр, используемый при ресэмплинге (уменьшении) изображений для получения эскизов.
Количество операций в буфере отмены | Задаёт размер буфера, используемого для хранения данных для отмены операций. Вы можете отменить не более указанного количества операций подряд (при заполнении буфера удаляются данные о самых ранних операциях). Большой размер буфера может потребовать значительного объёма памяти для хранения (особенно объёмными являются операции удаления и редактирования изображений).

См. также:

Настройки программы :: Общие
Настройки программы :: Режим просмотра
Настройки программы :: Диалоги
Настройки программы :: Инструменты
Хранение настроек программы в файле


Настройки программы :: Режим просмотра

Окно просмотра поверх всех окон | Не позволяет окну просмотра опускаться ниже других окон, когда оно неактивно. Имеет смысл только в оконном режиме.
Полноэкранный режим | Если включено, то при входе в режим просмотра сразу устанавливается полноэкранный режим — режим, когда скрываются все элементы оформления Windows (в том числе и Панель задач). При этом можно переключаться в оконный режим и обратно нажатием клавиши F или средней клавиши мыши.
Удерживать курсор мыши над кнопкой панели инструментов | Если включено, курсор мыши остаётся над одним и тем же местом панели инструментов при изменении размеров окна. Это позволяет, например, последовательно нажимать кнопки Следующее изображение или Уменьшить, не двигая мышью.
Скрывать указатель мыши в полноэкранном режиме | При входе в полноэкранный режим указатель мыши скрывается (чтоб не маячил перед глазами).
Цвет фона окна просмотра | Определяет цвет не закрытых изображением частей окна просмотра. По умолчанию — чёрный.
Отображать панель инструментов | Разрешает/запрещает показ панели инструментов режима просмотра.
Смена изображений
Подгонять размер окна под размер изображения | Изменяет размер окна так, чтобы изображение при текущем выбранном масштабе целиком помещалось в нём. Имеет смысл только в оконном режиме.
Центрировать окно на рабочем столе | Помещает окно просмотра в центре рабочего стола. Имеет смысл только в оконном режиме.
Сжимать изображение до размера окна | Если изображение больше размеров окна, оно пропорционально уменьшается (так, чтобы точно вписаться в окно).
Растягивать изображение до размера окна | Если изображение меньше размеров окна, оно пропорционально растягивается (так, чтобы точно вписаться в окно).
Циклический просмотр | Если включено, после просмотра последнего изображения программа переходит к первому, и наоборот.
Предекодировать следующее изображение | Эта опция разрешает фоновое упреждающее декодирование изображений, что позволяет переходить к следующему изображению более быстро (следующее изображение декодируется во время просмотра текущего). Этот режим требует дополнительной памяти для хранения данных следующего изображения.
Кэшировать предыдущее изображение | Если опция включена, последнее просмотренное изображение не удаляется из памяти, что позволяет быстро возвращаться к предыдущему изображению. Этот режим требует дополнительной памяти для хранения данных предыдущего изображения.
Шаг изменения масштаба | Определяет, с каким шагом будет изменяться масштаб при увеличении/уменьшении изображения (клавишами + и - на цифровой клавиатуре или колёсиком мыши при нажатом Ctrl).
Отображать в заголовке окна | Позволяет выбрать свойства изображения, которые будут отображаться в заголовке окна. Имеет смысл только в оконном режиме.
Метод ресэмплинга изображения | Определяет интерполяционный фильтр, используемый при ресэмплинге (масштабировании) изображений при просмотре.
Отображаемая информация
Отображать информацию об изображении | Если включено, информация (см. ниже) отображается.
Данные изображения | Определяет, какие свойства изображения отображаются на экране в режиме просмотра.
Шрифт | Задаёт шрифт, используемый для отрисовки описания изображения
Цвет фона | Задаёт цвет фона, на котором отрисовывается информационная строка. См. следующий параметр.
Непрозрачность фона | Значение в диапазоне от 0 (прозрачный фон, т.е. его нет) до 255 (непрозрачный фон). Позволяет задать степень прозрачности фона информационной строки.
Просмотр слайдов
Время показа изображения | Задаёт интервал времени в миллисекундах между автоматической сменой изображения в режиме показа слайдов (режим показа слайдов активизируется в режиме просмотра нажатием кнопки Pause, через панель инструментов или контекстное меню).
Циклический просмотр | Если включен, то при просмотре слайдов программа автоматически переходит к просмотру первого изображения в группе после просмотра последнего. В противном случае по достижении последнего изображения показ слайдов прекращается.

См. также:

Настройки программы :: Общие
Настройки программы :: Режим обзора
Настройки программы :: Диалоги
Настройки программы :: Инструменты
Хранение настроек программы в файле


Настройки программы :: Диалоги

Отображать заставку при запуске | Если включено, при запуске программы отображается окошко заставки.
Анимированное скрытие заставки при запуске | Если включено, заставка, отображаемая при запуске, будет плавно "растворяться" после того, как программа вошла в ждущий режим (только на Windows 2000 и более поздних).
Анимированное скрытие диалога «О программе» | Если включено, диалог О программе будет плавно "растворяться" при закрытии (только на Windows 2000 и более поздних).
Подтверждения
Перед удалением группы | Если включено, перед удалением группы выдаётся соответствующий запрос.
Перед удалением изображений | Если включено, перед удалением изображений выдаётся соответствующий запрос.
Перед удалением представления | Если включено, перед удалением представления выдаётся соответствующий запрос.
Перед сохранением файла устаревшей версии | Если включено, то при сохранении файла более старой версии, чем текущая, выдаётся предупреждение о возможной потере данных.
Перед выходом (при сохранённом фотоальбоме) | Если включено, перед выходом из программы выдаётся запрос даже при неизменённом фотоальбоме (при изменённом фотоальбоме запрос выдаётся всегда).
Уведомления
После копирования изображений с помощью Drag'n'Drop | Если включено, после копирования изображений перетаскиванием выдаётся информация о том, сколько реально изображений было скопировано.
После перемещения изображений с помощью Drag'n'Drop | Если включено, после перемещения изображений перетаскиванием выдаётся информация о том, сколько реально изображений было перенесено.
После вставки изображений из буфера обмена | Если включено, после вставки изображений из буфера обмена выдаётся информация о том, сколько реально изображений было вставлено.
Мастер добавления изображений
Отображать скрытые файлы и папки | Контролирует отображение файлов и папок, имеющих атрибут Скрытый.
Пропускать страницу отметки файлов | Если включено, то после выбора файлов/папок в Мастере добавления изображений PhoA сразу начинает процесс добавления изображений (пропуская страницу отметки файлов).
Отображать протокол добавления только при наличии ошибок | Если включено, протокол добавления будет отображаться только в том случае, если при добавлении происходили сбои, в противном случае окно Мастера добавления закроется сразу по окончании процесса добавления изображений. Если выключено, протокол будет отображаться всегда по завершении процесса.
Автозаполнение даты изображения из: | Настраивает свойства, которые будут участвовать в автозаполнении даты изображения при добавлении.
Переписывать дату, если она уже указана | Заставляет программу производить автозаполнение даты изображения (переписывать дату), даже если дата изображения уже введена.
Автозаполнение времени изображения из: | Настраивает свойства, которые будут участвовать в автозаполнении времени изображения при добавлении.
Переписывать время, если оно уже указано | Заставляет программу производить автозаполнение времени изображения (переписывать время), даже если время изображения уже введено.
Автозаполнение преобразований изображения из метаданных | Применяет требуемые преобразования к изображению в процессе автозаполнения его свойств при добавлении изображений. Потребность в преобразованиях определяется на основе значения метатега Orientation.
Окно свойств изображений
Страница, отображаемая при открытии диалога | Задаёт страницу свойств, которую требуется отображать по умоланию при открытии диалога свойств изображений.
Сразу раскрывать свойства файлов | Если включено, свойства файлов на странице свойств раскрываются сразу полностью.
Сразу раскрывать метаданные изображений | Если включено, метаданные изображений на странице метаданных раскрываются сразу полностью.
Мастер операций с файлами изображений
Подтверждение для операции копирования файлов | Если включено, перед непосредственным запуском процесса копирования файлов программа запрашивает подтверждения.
Подтверждение для операции перемещения файлов | Если включено, перед непосредственным запуском процесса перемещения файлов программа запрашивает подтверждения.
Подтверждение для операции удаления файлов | Если включено, перед непосредственным запуском процесса удаления файлов программа запрашивает подтверждения.
Подтверждение для операции перестройки эскизов | Если включено, перед непосредственным запуском процесса перестройки эскизов программа запрашивает подтверждения.
Отображать протокол операции только при наличии ошибок | Если включено, протокол файловой операции будет отображаться только в том случае, если в процессе выполнения её происходили сбои, в противном случае окно Мастера операций с файлами закроется сразу по окончании операции. Если выключено, протокол будет отображаться всегда по завершении процесса.

См. также:

Настройки программы :: Общие
Настройки программы :: Режим обзора
Настройки программы :: Режим просмотра
Настройки программы :: Инструменты
Хранение настроек программы в файле


Настройки программы :: Инструменты

Страница Инструменты Диалога настроек служит для определения набора доступных инструментов.

Порядок следования инструментов в списке определяет порядок их следования в меню.

Вы можете менять его, перетаскивая записи мышью, с помощью команд контекстного меню или клавишами Ctrl+Up, Ctrl+Down.

Чтобы отобразить меню для инструмента, нажмите кнопку слева от пункта, правую клавишу мыши или клавишу Пробел.

Удаление инструмента производится командой контекстного меню Удалить или клавишей Del.

Чтобы просмотреть или изменить свойства инструмента, выберите пункт контекстного меню Изменить..., нажмите комбинацию клавиш Alt+Enter или сделайте двойной щелчок мышью на пункте. При этом отобразится Диалог свойств инструмента.

Чтобы добавить новую запись инструмента, выберите команду Изменить... для последней, незаполненной записи списка.

Выбор столбцов

Вы можете выбрать, какие столбцы в таблице инструментов отображаются с помощью контекстного меню, вызываемого нажатием правой кнопки мыши на заголовке таблицы. Кроме того, Вы можете изменять порядок следования столбцов, перетаскивая их мышью.

См. также:

Инструменты
Настройки программы :: Общие
Настройки программы :: Режим обзора
Настройки программы :: Режим просмотра
Настройки программы :: Диалоги
Хранение настроек программы в файле


Хранение настроек программы в файле

Программа PhoA, как и подавляющее большинство прочих программ для Windows, автоматически сохраняет установленные пользователем настройки в системном реестре. К сохраняемым относятся не только настройки, задаваемые с помощью окна настроек программы, но и некоторые другие параметры интерфейса — такие, как размеры окон, положение панелей инструментов и история списков.

Кроме того, настройки можно сохранить в виде файла — например, если Вы хотите запустить программу на другом компьютере, не настраивая заново все её параметры.

PhoA позволяет сохранить текущие настройки программы в виде стандартного ini-файла Windows. Делается это выбором пункта меню Файл | Сохранить настройки в файл... или нажатием комбинации клавиш Shift+Ctrl+S. При этом отображается стандартный диалог сохранения файла. По умолчанию программа предлагает сохранить настройки в файл phoa.ini.

Если настройки можно сохранить в файл, то, как вы вероятно догадываетесь, их можно и загрузить из файла. Чтобы сделать это, выберите пункт меню Файл | Загрузить настройки из файла... или нажмите комбинацию клавиш Shift+Ctrl+O. В появившемся диалоге нужно выбрать сохранённый Вами ini-файл настроек. По умолчанию программа подставляет имя файла phoa.ini.

Файл phoa.ini имеет особое значение — если он находится в том же каталоге, что и сама программа (phoa.exe), то при запуске PhoA загрузит настройки из него автоматически. Это поведение по умолчанию можно изменить в Общих настройках программы — переключатель Загружать настройки из phoa.ini при его наличии в каталоге программы можно выключить, в этом случае автозагрузки phoa.ini не происходит.

NB:
  • Как Вам, возможно, уже очевидно, загрузка настроек происходит в такой последовательности: сначала данные из реестра, потом (если это включено) — из файла phoa.ini. Таким образом, если какие-то настройки в файле отсутствуют, они берутся из реестра.
  • В ini-файле настроек сохраняются только те параметры программы, которые не относятся к данному компьютеру. Размеры, положение, состояния окон, положение и видимость панелей инструментов, а также настройки инструментов всегда сохраняются только локально, в реестре.

См. также:

Настройки программы :: Общие
Настройки программы :: Режим обзора
Настройки программы :: Режим просмотра
Настройки программы :: Диалоги
Настройки программы :: Инструменты


Мастер операций с файлами изображений :: Опции восстановления ссылок на файлы

Эта страница Мастера позволяет задать параметры восстановления ссылок на файлы изображений.

Пока не реализовано и не документировано...

См. также:

Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора


Мастер операций с файлами изображений :: Операция восстановления ссылок на файлы

Эта операция позволяет восстановить испорченные по разным причинам ссылки на файлы изображений путём поиска соответствующих файлов в заданной папке.

Чтобы выполнить эту операцию, необходимо запустить Мастер операций с файлами изображений и на странице выбора задачи выбрать Восстановить ссылки на файлы изображений.

Далее последовательность страниц такова:

  • Выбор изображений для операции
  • Выбор папки назначения
  • Опции восстановления ссылок на файлы
  • Процесс выполнения операции
  • Протокол операции

См. также:

Мастер операций с файлами изображений
Режим обзора
Работа в режиме обзора